Scientific Linux セキュリティ更新: SL7.x i686/x86_64 の cyrus-sasl (2022:0666)

high Nessus プラグイン ID 158348

概要

リモートの Scientific Linux ホストに 1 つ以上のセキュリティ更新プログラムがありません。

説明

リモートの Scientific Linux 7 ホストのパッケージは、SLSA-2022: 0666-1 のアドバイザリに記載されている脆弱性の影響を受けます。

- cyrus-sasl: SQL 入力を適切にエスケープできないため、攻撃者が任意の SQL コマンドを実行する可能性があります (CVE-2022-24407)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://www.scientificlinux.org/category/sl-errata/slsa-20220666-1

プラグインの詳細

深刻度: High

ID: 158348

ファイル名: sl_20220224_cyrus_sasl_on_SL7_x.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/2/24

更新日: 2022/3/7

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.5

Temporal Score: 4.8

ベクトル: AV:N/AC:L/Au:S/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-24407

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:fermilab:scientific_linux, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-debuginfo, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-devel, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-gs2, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-gssapi, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-ldap, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-lib, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-md5, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-ntlm, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-plain, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-scram, p-cpe:/a:fermilab:scientific_linux:cyrus-sasl-sql

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/2/24

脆弱性公開日: 2022/2/23

参照情報

CVE: CVE-2022-24407