openSUSE 15 セキュリティ更新: expat (openSUSE-SU-2022:0713-1)

critical Nessus プラグイン ID 158627

言語:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートのSUSE Linux SUSE15ホストには、openSUSE-SU-2022:0713-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 2.4.5より前の Expat (別名 libexpat ) の xmltok_impl.c には、UTF-8 文字が特定のコンテキストで有効かどうかのチェックなど、エンコーディングの特定の検証がありません。 (CVE-2022-25235)

- 2.4.5より前の Expat (別名 libexpat) の xmlparse.c により、攻撃者が名前空間 URI に名前空間セパレーター文字を挿入することが可能です。 (CVE-2022-25236)

- 2.4.5より前の Expat (別名 libexpat) では、攻撃者が DTD 要素のネストの深さを深くすることで、build_model でスタック枯渇を引き起こす可能性があります。(CVE-2022-25313)

- 2.4.5より前の Expat (別名 libexpat) では、copyString に整数オーバーフローがあります。(CVE-2022-25314)

- 2.4.5より前の Expat (別名 libexpat) では、storeRawNames に整数オーバーフローがあります。(CVE-2022-25315)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://bugzilla.suse.com/1196025

https://bugzilla.suse.com/1196026

https://bugzilla.suse.com/1196168

https://bugzilla.suse.com/1196169

https://bugzilla.suse.com/1196171

http://www.nessus.org/u?a2424e4e

https://www.suse.com/security/cve/CVE-2022-25235

https://www.suse.com/security/cve/CVE-2022-25236

https://www.suse.com/security/cve/CVE-2022-25313

https://www.suse.com/security/cve/CVE-2022-25314

https://www.suse.com/security/cve/CVE-2022-25315

プラグインの詳細

深刻度: Critical

ID: 158627

ファイル名: openSUSE-2022-0713-1.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/3/5

更新日: 2022/5/25

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-25315

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:opensuse:expat, p-cpe:/a:novell:opensuse:libexpat-devel, p-cpe:/a:novell:opensuse:libexpat-devel-32bit, p-cpe:/a:novell:opensuse:libexpat1, p-cpe:/a:novell:opensuse:libexpat1-32bit, cpe:/o:novell:opensuse:15.3

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/3/4

脆弱性公開日: 2022/2/16

参照情報

CVE: CVE-2022-25235, CVE-2022-25236, CVE-2022-25313, CVE-2022-25314, CVE-2022-25315