RHEL 8: expat (RHSA-2022: 1070)

critical Nessus プラグイン ID 159288

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモート Redhat Enterprise Linux 8 ホストにインストールされているパッケージは、RHSA-2022: 1070 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- expat: 無効な形式の 2 バイトおよび 3 バイトの UTF-8 シーケンスにより、任意のコードが実行される可能性があります (CVE-2022-25235)

- expat: xmlns[: prefix] 属性値の Namespace-separator により、任意のコードが実行される可能性があります (CVE-2022-25236)

- expat: storeRawNames() の整数オーバーフロー (CVE-2022-25315)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるexpatおよび/またはexpat-develパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/20.html

https://cwe.mitre.org/data/definitions/190.html

https://cwe.mitre.org/data/definitions/787.html

https://cwe.mitre.org/data/definitions/838.html

https://access.redhat.com/security/cve/CVE-2022-25235

https://access.redhat.com/security/cve/CVE-2022-25236

https://access.redhat.com/security/cve/CVE-2022-25315

https://access.redhat.com/errata/RHSA-2022:1070

https://bugzilla.redhat.com/2056363

https://bugzilla.redhat.com/2056366

https://bugzilla.redhat.com/2056370

プラグインの詳細

深刻度: Critical

ID: 159288

ファイル名: redhat-RHSA-2022-1070.nasl

バージョン: 1.3

タイプ: local

エージェント: unix

公開日: 2022/3/29

更新日: 2022/5/25

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-25315

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:rhel_aus:8.2, cpe:/o:redhat:rhel_e4s:8.2, cpe:/o:redhat:rhel_eus:8.2, cpe:/o:redhat:rhel_tus:8.2, p-cpe:/a:redhat:enterprise_linux:expat, p-cpe:/a:redhat:enterprise_linux:expat-devel

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/3/28

脆弱性公開日: 2022/2/16

参照情報

CVE: CVE-2022-25235, CVE-2022-25236, CVE-2022-25315

RHSA: 2022:1070

CWE: 20, 190, 787, 838