RHEL 7: カーネル (RHSA-2022: 1107)

high Nessus プラグイン ID 159314

概要

リモートのRed Hatホストに1つ以上のセキュリティ更新プログラムがありません。

説明

リモートの Redhat Enterprise Linux 7 ホストにインストールされているパッケージは、RHSA-2022: 1107 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- kernel: ローカルの権限昇格が発生する可能性がある、unix_gc() でのメモリ解放後使用 (Use-After-Free) (CVE-2021-0920)

- kernel: fget: fd が参照された後も fd がまだ存在することを確認 (CVE-2021-4083)

- kernel:TLB フラッシュの欠如による権限昇格の可能性 (CVE-2022-0330)

- kernel:usercopy の失敗によるメモリ解放後使用 (use-after-free) の悪用 (CVE-2022-22942)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cwe.mitre.org/data/definitions/281.html

https://cwe.mitre.org/data/definitions/416.html

https://access.redhat.com/security/cve/CVE-2021-0920

https://access.redhat.com/security/cve/CVE-2021-4083

https://access.redhat.com/security/cve/CVE-2022-0330

https://access.redhat.com/security/cve/CVE-2022-22942

https://access.redhat.com/errata/RHSA-2022:1107

https://bugzilla.redhat.com/2029923

https://bugzilla.redhat.com/2031930

https://bugzilla.redhat.com/2042404

https://bugzilla.redhat.com/2044809

プラグインの詳細

深刻度: High

ID: 159314

ファイル名: redhat-RHSA-2022-1107.nasl

バージョン: 1.6

タイプ: local

エージェント: unix

公開日: 2022/3/29

更新日: 2022/5/25

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Medium

Base Score: 6.9

Temporal Score: 6

ベクトル: AV:L/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-4083

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7.5

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

CVSS スコアのソース: CVE-2022-0330

脆弱性情報

CPE: cpe:/o:redhat:rhel_e4s:7.6, p-cpe:/a:redhat:enterprise_linux:kernel, p-cpe:/a:redhat:enterprise_linux:kernel-abi-whitelists, p-cpe:/a:redhat:enterprise_linux:kernel-bootwrapper, p-cpe:/a:redhat:enterprise_linux:kernel-debug, p-cpe:/a:redhat:enterprise_linux:kernel-debug-devel, p-cpe:/a:redhat:enterprise_linux:kernel-devel, p-cpe:/a:redhat:enterprise_linux:kernel-tools, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs, p-cpe:/a:redhat:enterprise_linux:kernel-tools-libs-devel, p-cpe:/a:redhat:enterprise_linux:perf, p-cpe:/a:redhat:enterprise_linux:python-perf

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/3/29

脆弱性公開日: 2021/12/15

CISAの既知の悪用日: 2022/6/13

参照情報

CVE: CVE-2021-0920, CVE-2021-4083, CVE-2022-0330, CVE-2022-22942

RHSA: 2022:1107

CWE: 281, 416