Apache Shiro のデフォルトの暗号鍵 (CVE-2016-4437)

high Nessus プラグイン ID 159323

概要

Java セキュリティフレームワークは、デフォルトの暗号鍵を使用します。

説明

Apache Shiro は、明示的に構成されていない場合、「remember me」機能に対してデフォルトの暗号鍵を使用します。認証されていないリモートの攻撃者がこれを悪用し、特別に細工したリクエストで任意のコードを実行したり、または、セキュリティ上の制約によって保護されるコンテンツにアクセスしたりする可能性があります。

ソリューション

Apache Shiro 1.2.5以降にアップグレードして、秘密の暗号鍵が構成されていることを確認するか、「remember me」機能を無効にしてください。

関連情報

http://www.nessus.org/u?fd9839a6

http://www.nessus.org/u?25ff751a

プラグインの詳細

深刻度: High

ID: 159323

ファイル名: apache_shiro_cve-2016-4437.nbin

バージョン: 1.9

タイプ: remote

ファミリー: CGI abuses

公開日: 2022/3/30

更新日: 2022/7/19

リスク情報

VPR

リスクファクター: Critical

スコア: 9

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5.9

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2016-4437

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:shiro

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

Nessus によりエクスプロイト済み: true

パッチ公開日: 2016/5/18

脆弱性公開日: 2016/6/3

CISAの既知の悪用日: 2022/5/3

エクスプロイト可能

Metasploit (Apache Shiro v1.2.4 Cookie RememberME Deserial RCE)

参照情報

CVE: CVE-2016-4437