SUSE SLES15セキュリティ更新プログラム: カーネル (SUSE-SU-2022:1037-1)

high Nessus プラグイン ID 159357

言語:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLES15ホストには、SUSE-SU-2022:1037-1のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- af_unix.c の unix_scm_to_skb に、競合状態によるメモリ解放後使用 (use-after-free) のバグの可能性があります。これにより、システム実行権限が必要なローカルでの権限昇格が引き起こされる可能性があります。悪用はユーザーの操作を必要としません。製品: Android。バージョン: AndroidカーネルAndroid ID:A-196926917References:
Upstream カーネル (CVE-2021-0920)

- ufshcd.c の ufshcd_eh_device_reset_handler では、境界チェックが欠落しているために領域外読み取りが発生する可能性があります。これにより、システム実行権限が必要なローカルでの情報漏洩が引き起こされる可能性があります。
悪用はユーザーの操作を必要としません。製品: Android。バージョン: AndroidカーネルAndroid ID:
A-194696049References: Upstream カーネル (CVE-2021-39657)

- 5.16.3より前の Linux カーネルの fs/f2fs/gc.c の gc_data_segment で、特別なファイルが考慮されず、move_data_page NULL ポインターデリファレンスを引き起こします。(CVE-2021-44879)

- Linux カーネルの memstick の drivers/memstick/host/rtsx_usb_ms.c の rtsx_usb_ms_drv_remove にメモリ解放後使用 (Use After Free) の脆弱性が見つかりました。この欠陥では、ユーザーの権限を持つローカルの攻撃者がシステムの機密性に影響を与える可能性があります。この欠陥は、5.14 rc1 より前のカーネルバージョンに影響を与えます。(CVE-2022-0487)

- ユーザーが悪意のある UDF イメージに対して udf_file_write_iter 関数をトリガーする方法に、Linux カーネル UDF ファイルシステム機能の欠陥のある NULL ポインターデリファレンスが見つかりました。ローカルユーザーがこの欠陥を使用して、システムをクラッシュする可能性があります。実際のところ、Linux カーネル 4.2-rc1 から 5.17-rc2 まで。(CVE-2022-0617)

- 5.16.5より以前の Linux カーネルに問題が発見されました。アプリケーションが O_DIRECTORY フラグを設定し、通常のファイルを開こうとすると、nfs_atomic_open() は通常の検索を実行します。通常のファイルが見つかった場合、ENOTDIR が発生しますが、サーバーは初期化されていないデータをファイル記述子で返します。(CVE-2022-24448)

- 5.16.8までの Linux カーネルの drivers/usb/gadget/legacy/inode.c が、dev-> buf リリースを不適切に処理します。
(CVE-2022-24958)

- 5.16.5より前の Linux カーネルで問題が発見されました。drivers/net/hamradio/yam.c の yam_siocdevprivate にメモリリークがあります。(CVE-2022-24959)

- 5.16.10より前の Linux カーネルの drivers/usb/gadget/composite.c に問題が発見されました。USB Gadget サブシステムには、インターフェイス OS 記述子リクエスト (大きな配列インデックスを持つものと NULL 関数ポインターの取得に関連するもの) の特定の検証がありません。メモリ破損が発生する可能性があります。
(CVE-2022-25258)

- Linux カーネル 5.4 〜 5.6.10の net/netfilter/nf_dup_netdev.c により、ヒープ領域外書き込みのためにローカルユーザーが権限を取得する可能性があります。これは、nf_tables_offload に関連しています。(CVE-2022-25636)

- 5.16.12までの Linux カーネルの drivers/nfc/st21nfca/se.c の st21nfca_connectivity_event_received には、EVT_TRANSACTION バッファオーバーフローがあります。長さのパラメーターが信頼できないためです。(CVE-2022-26490)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://bugzilla.suse.com/1176447

https://bugzilla.suse.com/1176774

https://bugzilla.suse.com/1178134

https://bugzilla.suse.com/1179439

https://bugzilla.suse.com/1181147

https://bugzilla.suse.com/1191428

https://bugzilla.suse.com/1192273

https://bugzilla.suse.com/1193731

https://bugzilla.suse.com/1193787

https://bugzilla.suse.com/1193864

https://bugzilla.suse.com/1194463

https://bugzilla.suse.com/1194516

https://bugzilla.suse.com/1195211

https://bugzilla.suse.com/1195254

https://bugzilla.suse.com/1195403

https://bugzilla.suse.com/1195612

https://bugzilla.suse.com/1195897

https://bugzilla.suse.com/1195905

https://bugzilla.suse.com/1195939

https://bugzilla.suse.com/1195949

https://bugzilla.suse.com/1195987

https://bugzilla.suse.com/1196079

https://bugzilla.suse.com/1196095

https://bugzilla.suse.com/1196132

https://bugzilla.suse.com/1196155

https://bugzilla.suse.com/1196299

https://bugzilla.suse.com/1196301

https://bugzilla.suse.com/1196433

https://bugzilla.suse.com/1196468

https://bugzilla.suse.com/1196472

https://bugzilla.suse.com/1196627

https://bugzilla.suse.com/1196723

https://bugzilla.suse.com/1196779

https://bugzilla.suse.com/1196830

https://bugzilla.suse.com/1196836

https://bugzilla.suse.com/1196866

https://bugzilla.suse.com/1196868

http://www.nessus.org/u?0509572b

https://www.suse.com/security/cve/CVE-2021-0920

https://www.suse.com/security/cve/CVE-2021-39657

https://www.suse.com/security/cve/CVE-2021-44879

https://www.suse.com/security/cve/CVE-2022-0487

https://www.suse.com/security/cve/CVE-2022-0617

https://www.suse.com/security/cve/CVE-2022-0644

https://www.suse.com/security/cve/CVE-2022-24448

https://www.suse.com/security/cve/CVE-2022-24958

https://www.suse.com/security/cve/CVE-2022-24959

https://www.suse.com/security/cve/CVE-2022-25258

https://www.suse.com/security/cve/CVE-2022-25636

https://www.suse.com/security/cve/CVE-2022-26490

プラグインの詳細

深刻度: High

ID: 159357

ファイル名: suse_SU-2022-1037-1.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/3/31

更新日: 2022/5/25

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Critical

スコア: 9.2

CVSS v2

リスクファクター: Medium

Base Score: 6.9

Temporal Score: 6

ベクトル: AV:L/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-25636

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 7.5

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

CVSS スコアのソース: CVE-2022-26490

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:kernel-azure, p-cpe:/a:novell:suse_linux:kernel-azure-devel, p-cpe:/a:novell:suse_linux:kernel-devel-azure, p-cpe:/a:novell:suse_linux:kernel-source-azure, p-cpe:/a:novell:suse_linux:kernel-syms-azure, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/3/30

脆弱性公開日: 2021/12/15

CISAの既知の悪用日: 2022/6/13

参照情報

CVE: CVE-2021-0920, CVE-2021-39657, CVE-2021-44879, CVE-2022-0487, CVE-2022-0617, CVE-2022-0644, CVE-2022-24448, CVE-2022-24958, CVE-2022-24959, CVE-2022-25258, CVE-2022-25636, CVE-2022-26490

SuSE: SUSE-SU-2022:1037-1