Amazon Corretto Java 8.x< 8.222.10.1複数の脆弱性

medium Nessus プラグイン ID 159424

概要

Amazon Corretto複数の脆弱性の影響を受けています。

説明

リモートホストにインストールされている Amazon Corretto のバージョンは、8 < 8.222.10.1より前です。したがって、corretto-8-2019-Jul-16 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Security (CVE-2019-2745, CVE-2019-2786)

- Utilities (CVE-2019-2762, CVE-2019-2769)

- Networking (CVE-2019-2766, CVE-2019-2816)

- JCE (CVE-2019-2842)

- AWT (libpng) (CVE-2019-7317)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Amazon Corretto Java 8.222.10.1以降に更新してください

関連情報

http://www.nessus.org/u?a0f77c73

プラグインの詳細

深刻度: Medium

ID: 159424

ファイル名: amazon_corretto_8_222_10_1.nasl

バージョン: 1.5

タイプ: local

エージェント: windows, macosx, unix

ファミリー: Misc.

公開日: 2022/4/1

更新日: 2022/5/6

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.1

CVSS v2

リスクファクター: Medium

Base Score: 5.8

Temporal Score: 4.3

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-2816

CVSS v3

リスクファクター: Medium

Base Score: 5.1

Temporal Score: 4.5

ベクトル: CVSS:3.0/AV:L/AC:H/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2019-2745

脆弱性情報

CPE: cpe:/a:amazon:corretto

必要な KB アイテム: installed_sw/Java

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2019/7/16

脆弱性公開日: 2019/1/25

参照情報

CVE: CVE-2019-2745, CVE-2019-2762, CVE-2019-2766, CVE-2019-2769, CVE-2019-2786, CVE-2019-2816, CVE-2019-2842, CVE-2019-7317

IAVA: 2019-A-0164-S