WordPress プラグイン「Social Warfare」< 3.5.3 XSS

medium Nessus プラグイン ID 159570

概要

リモートの WordPress アプリケーションには、クロスサイトスクリプティングの脆弱性が存在するプラグインがインストールされています。

説明

リモートホストで実行されている WordPress アプリケーションには、 3.5.3 より前のバージョンの「Social Warfar」プラグインがあるため、wp-admin/admin-post.php?swp_debug=load_options swp_url parameter の格納型クロスサイトスクリプティングの脆弱性の影響を受けます。

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

管理ダッシュボードを使用して、「Social Warfare」プラグインをバージョン 3.5.3 以降に更新してください。

関連情報

https://wordpress.org/plugins/social-warfare/#developers

https://wpscan.com/vulnerability/9238

プラグインの詳細

深刻度: Medium

ID: 159570

ファイル名: wordpress_plugin_social_warfare_3_5_3.nasl

バージョン: 1.2

タイプ: remote

ファミリー: CGI abuses

公開日: 2022/4/7

更新日: 2022/4/7

リスク情報

VPR

リスクファクター: Medium

スコア: 4.6

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.7

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:N/I:P/A:N

現状ベクトル: CVSS2#E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2019-9978

CVSS v3

リスクファクター: Medium

Base Score: 6.1

Temporal Score: 5.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: CVSS:3.0/E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:wordpress:wordpress:*:*:*:*:*:*:*:*

必要な KB アイテム: installed_sw/WordPress, www/PHP

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2019/3/21

脆弱性公開日: 2019/3/21

CISAの既知の悪用日: 2022/5/3

エクスプロイト可能

Elliot (WordPress Social Warfare 3.5.2 RCE)

参照情報

CVE: CVE-2019-9978