FreeBSD:Ruby -- 文字列から浮動小数点への変換におけるバッファオーバーラン (06ed6a49-bad4-11ec-9cfe-0800270512f4)

high Nessus プラグイン ID 159694

言語:

概要

リモートの FreeBSD ホストに 1 つ以上のセキュリティ関連の更新プログラムがありません。

説明

リモートホストにインストールされている FreeBSD のバージョンは、テスト済みバージョンより前です。したがって、06ed6a49-bad4-11ec-9cfe-0800270512f4 のアドバイザリに記載されている脆弱性の影響を受けます。

- piao レポート : String を Float に変換する内部関数のバグにより、Kernel#Float や String#to_f could などの一部の変換メソッドがバッファオーバーリードを引き起こす可能性があります。
典型的な結果として、セグメンテーション違反によるプロセスの終了がありますが、限られた状況では、メモリの不正な読み取りに悪用される可能性があります。(CVE-2022-28739)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

http://www.nessus.org/u?64fea386

http://www.nessus.org/u?ac8afa29

プラグインの詳細

深刻度: High

ID: 159694

ファイル名: freebsd_pkg_06ed6a49bad411ec9cfe0800270512f4.nasl

バージョン: 1.3

タイプ: local

公開日: 2022/4/13

更新日: 2022/5/20

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-28739

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:freebsd:freebsd:ruby, p-cpe:/a:freebsd:freebsd:ruby27, p-cpe:/a:freebsd:freebsd:ruby30, p-cpe:/a:freebsd:freebsd:ruby31, cpe:/o:freebsd:freebsd

必要な KB アイテム: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/4/13

脆弱性公開日: 2022/4/12

参照情報

CVE: CVE-2022-28739