PHP < 4.3.10 / 5.0.3 の複数の脆弱性

high Nessus プラグイン ID 15973

概要

リモート Web サーバーが使用するバージョンの PHP は、複数の脆弱性の影響を受ける可能性があります。

説明

バナーによると、リモートホストにインストールされている PHP のバージョンは、4.3.10 / 5.0.3 より前です。このため、特定の状況下で、攻撃者が一部の関数に任意のデータを渡すことができるか、safe_mode をバイパスできる場合に、攻撃者がリモートホストで任意のコードを実行できることがある、複数のセキュリティ問題の影響を受けます。

ソリューション

PHP 5.0.3 または 4.3.10 にアップグレードしてください。

関連情報

http://www.php.net/ChangeLog-5.php#5.0.3

プラグインの詳細

深刻度: High

ID: 15973

ファイル名: php45_multiple_flaws.nasl

バージョン: 1.25

タイプ: remote

ファミリー: CGI abuses

公開日: 2004/12/15

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.8

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

パッチ公開日: 2004/12/14

脆弱性公開日: 2004/11/23

参照情報

CVE: CVE-2004-1018, CVE-2004-1019, CVE-2004-1020, CVE-2004-1063, CVE-2004-1064, CVE-2004-1065

BID: 11964, 11981, 11992, 12045

CWE: 20