GitLab 8.3.x < 14.7.7 / 14.8.x < 14.8.5 / 14.9.x < 14.8.2 XSS

medium Nessus プラグイン ID 159829

概要

リモート Web サーバーで実行されているソース管理アプリケーションは、クロスサイトスクリプティングの脆弱性の影響を受けます。

説明

GitLab CE/EE バージョン 14.7.7 より前の 8.3、14.8.5 より前の 14.8、および 14.9.2 より前の 14.9 でユーザー入力の処理が不適切なため、攻撃者は問題の説明やコメントなどのマルチワードマイルストーンの記載を悪用することで、蓄積型 XSS を悪用することが可能でした。

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

GitLab バージョン 14.7.7、14.8.5、14.9.2 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?eea093a9

プラグインの詳細

深刻度: Medium

ID: 159829

ファイル名: gitlab_cve-2022-1190.nasl

バージョン: 1.3

タイプ: remote

ファミリー: CGI abuses

公開日: 2022/4/18

更新日: 2022/5/6

リスク情報

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Low

Base Score: 3.5

Temporal Score: 2.6

ベクトル: AV:N/AC:M/Au:S/C:N/I:P/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-1190

CVSS v3

リスクファクター: Medium

Base Score: 5.4

Temporal Score: 4.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:gitlab:gitlab

必要な KB アイテム: installed_sw/GitLab

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/3/31

脆弱性公開日: 2022/3/31

参照情報

CVE: CVE-2022-1190

IAVA: 2022-A-0131-S