GitLab 14.8.6 / 14.9.x < 14.9.4 / 14.10.x < 14.10.1 複数の脆弱性

medium Nessus プラグイン ID 160670

概要

リモートの Web サーバーで実行されているソース管理アプリケーションは、複数の脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートの Web サーバーで実行されている GitLab のインスタンスは 14.8.6より前、14.9.4 より前の 14.9.x、14.10.1 より前の 14.10.xです。このため、以下の脆弱性の影響を受けます。

- GitLab CE / EE に不適切な承認の問題が存在するため、認証されたリモートの攻撃者が、ゲストプロジェクトメンバーとしてジョブのトレースログ (有効な場合) にアクセスする可能性があります。 (CVE-2022-1124)

- 認証されたパッケージリクエストのスロットル制限を不適切に検証しているため、認証されたリモートの攻撃者がスロットル制限をバイパスする可能性のある問題が GitLab に存在します。(CVE-2022-1428)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

GitLab バージョン 14.8.6、14.9.4、14.10.1 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?c46a7cbd

プラグインの詳細

深刻度: Medium

ID: 160670

ファイル名: gitlab_14_10_1.nasl

バージョン: 1.4

タイプ: combined

ファミリー: CGI abuses

公開日: 2022/5/6

更新日: 2022/6/13

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Low

スコア: 1.4

CVSS v2

リスクファクター: Low

Base Score: 3.5

Temporal Score: 2.6

ベクトル: AV:N/AC:M/Au:S/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-1124

CVSS v3

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:gitlab:gitlab

必要な KB アイテム: installed_sw/GitLab

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/5/2

脆弱性公開日: 2022/5/2

参照情報

CVE: CVE-2022-1124, CVE-2022-1428

IAVA: 2022-A-0187-S