Apache Tomcat 10.0.0.M1< 10.0.21の脆弱性

high Nessus プラグイン ID 160893

概要

リモートのApache Tomcatサーバーは、脆弱性の影響を受けます。

説明

リモートホストにインストールされている Tomcat のバージョンは10.0.21より前です。したがって、fixed_in_apache_tomcat_10.0.21_security-10 のアドバイザリに記載されている脆弱性の影響を受けます。

- EncryptInterceptor の Apache Tomcat 10.1.0-M1 から 10.1.0-M14、10.0.0-M1 から 10.0.20、9.0.13から 9.0.62 および 8.5.38 から 8.5.78 のドキュメントでは、Tomcat のクラスター化を信頼できないネットワーク上で有効にできると誤って記述されていました。これは誤りでした。EncryptInterceptor は機密性と整合性の保護を提供しますが、信頼できないネットワークでの実行に関連するすべてのリスク、特に DoS のリスクに対して保護しません。(CVE-2022-29885)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

Apache Tomcatバージョン10.0.21以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?739ceff6

http://www.nessus.org/u?f2824597

プラグインの詳細

深刻度: High

ID: 160893

ファイル名: tomcat_10_0_21.nasl

バージョン: 1.5

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2022/5/10

更新日: 2022/5/27

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.1

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-29885

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:tomcat

必要な KB アイテム: installed_sw/Apache Tomcat

エクスプロイトの容易さ: No known exploits are available

脆弱性公開日: 2022/5/10

参照情報

CVE: CVE-2022-29885

IAVA: 2022-A-0222