Microsoft Visual Studio Code のセキュリティ更新プログラム (2022 年 5 月)

high Nessus プラグイン ID 160944

概要

セキュリティ更新プログラムが不足するアプリケーションがリモートホストにインストールされています。

説明

リモートのWindowsホストにインストールされているMicrosoft Visual Studio Codeのバージョンは、1.67.1より前です。したがって、リモートコード実行の脆弱性の影響を受けます。

Nessus はこれらの問題のテストを行っておらず、代わりにアプリケーションの自己報告されたバージョンにのみ依存しています。

ソリューション

Microsoft Visual Studio Code 1.67.1以降にアップグレードしてください。

関連情報

https://code.visualstudio.com/updates/v1_67

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-30129

プラグインの詳細

深刻度: High

ID: 160944

ファイル名: microsoft_visual_studio_code_1_67_1.nasl

バージョン: 1.4

タイプ: local

ファミリー: Misc.

公開日: 2022/5/10

更新日: 2022/5/20

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Frictionless Assessment Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-30129

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:microsoft:visual_studio_code

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/5/10

脆弱性公開日: 2022/5/10

参照情報

CVE: CVE-2022-30129

IAVA: 2022-A-0200