DebianDLA-3011-1:vim - LTS セキュリティ更新

critical Nessus プラグイン ID 161242

概要

リモートの Debian ホストにセキュリティ関連の更新プログラムがありません。

説明

リモートの Debian 9 ホストには、dla-3011 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 8.2より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-0261、CVE-2022-0572)

- 8.2より前の GitHub リポジトリ vim/vim におけるバッファ開始前のメモリ位置のアクセス。
(CVE-2022-0351)

- 8.2より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-0413、CVE-2022-0443)

- 8.2.4646より前の GitHub リポジトリの vim/vim の utf_ptr2char のメモリ解放後使用 (Use-After-Free)。(CVE-2022-1154)

- 8.2.4895より前の GitHub リポジトリ vim/vim の append_command のメモリ解放後使用 (Use-After-Free)。この脆弱性は、ソフトウェアのクラッシュ、保護メカニズムのバイパス、メモリの変更、リモート実行の可能性があります (CVE-2022-1616)

- 8.2.4899より前の GitHub リポジトリ vim/vim の関数 cmdline_erase_chars におけるヒープベースのバッファオーバーフロー。
この脆弱性はソフトウェアのクラッシュ、メモリの変更、リモート実行の可能性があります (CVE-2022-1619)

- 8.2.4919より前の GitHub リポジトリ vim/vim の vim_strncpy find_word におけるヒープバッファオーバーフロー。この脆弱性は、ソフトウェアのクラッシュ、保護メカニズムのバイパス、メモリの変更、リモート実行の可能性があります (CVE-2022-1621)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

vimパッケージをアップグレードしてください。

Debian 9 Stretch では、これらの問題はバージョン 2 で修正されています

関連情報

https://security-tracker.debian.org/tracker/source-package/vim

https://www.debian.org/lts/security/2022/dla-3011

https://security-tracker.debian.org/tracker/CVE-2022-0261

https://security-tracker.debian.org/tracker/CVE-2022-0351

https://security-tracker.debian.org/tracker/CVE-2022-0413

https://security-tracker.debian.org/tracker/CVE-2022-0443

https://security-tracker.debian.org/tracker/CVE-2022-0572

https://security-tracker.debian.org/tracker/CVE-2022-1154

https://security-tracker.debian.org/tracker/CVE-2022-1616

https://security-tracker.debian.org/tracker/CVE-2022-1619

https://security-tracker.debian.org/tracker/CVE-2022-1621

https://packages.debian.org/source/stretch/vim

プラグインの詳細

深刻度: Critical

ID: 161242

ファイル名: debian_DLA-3011.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/5/17

更新日: 2022/5/17

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-1154

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:debian:debian_linux:vim, p-cpe:/a:debian:debian_linux:vim-athena, p-cpe:/a:debian:debian_linux:vim-common, p-cpe:/a:debian:debian_linux:vim-doc, p-cpe:/a:debian:debian_linux:vim-gnome, p-cpe:/a:debian:debian_linux:vim-gtk, p-cpe:/a:debian:debian_linux:vim-gtk3, p-cpe:/a:debian:debian_linux:vim-gui-common, p-cpe:/a:debian:debian_linux:vim-nox, p-cpe:/a:debian:debian_linux:vim-runtime, p-cpe:/a:debian:debian_linux:vim-tiny, p-cpe:/a:debian:debian_linux:xxd, cpe:/o:debian:debian_linux:9.0

必要な KB アイテム: Host/local_checks_enabled, Host/Debian/release, Host/Debian/dpkg-l

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/5/16

脆弱性公開日: 2022/1/18

参照情報

CVE: CVE-2022-0261, CVE-2022-0351, CVE-2022-0413, CVE-2022-0443, CVE-2022-0572, CVE-2022-1154, CVE-2022-1616, CVE-2022-1619, CVE-2022-1621