Apache 2.4.x < 2.4.52 mod_lua バッファオーバーフロー

critical Nessus プラグイン ID 161454

概要

リモート Web サーバーは、バッファオーバーフロー脆弱性の影響を受けます。

説明

リモートホストにインストールされているApache httpdのバージョンは、2.4.52より前です。したがって、マルチパートコンテンツを処理する際に mod_lua に関連する欠陥の影響を受けます。- 注意深く細工されたリクエスト本文により、mod_lua マルチパートパーサー (Lua スクリプトから呼び出された r: parsebody()) でバッファオーバーフローが発生する可能性があります。Apache httpd チームはこの脆弱性の悪用を認識していませんが、細工することは可能です。

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ頼っていることに注意してください。

ソリューション

Apacheバージョン2.4.52以降にアップグレードしてください。

プラグインの詳細

深刻度: Critical

ID: 161454

ファイル名: apache_2_4_52_CVE-2021-44790.nasl

バージョン: 1.4

タイプ: combined

エージェント: windows, macosx, unix

ファミリー: Web Servers

公開日: 2022/5/24

更新日: 2022/5/26

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-44790

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:httpd, cpe:/a:apache:http_server

必要な KB アイテム: installed_sw/Apache

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2021/12/20

脆弱性公開日: 2021/11/18

参照情報

CVE: CVE-2021-44790

IAVA: 2021-A-0604-S