SUSE SLES15 セキュリティ更新プログラム: grub2 (SUSE-SU-2022:2036-1)

high Nessus プラグイン ID 162131

Language:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLES15 / SLES_SAP15 ホストには、SUSE-SU-2022:2036-1 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- 細工された 16 ビットグレースケール PNG 画像により、ヒープ領域の領域外書き込みが発生する可能性があります。攻撃者がこれを利用して、ヒープデータの破損や最終的には任意コード実行を引き起こし、セキュアブート保護を回避する可能性があります。この問題は、攻撃者が重要な結果を達成するには、ヒープレイアウトに対して何らかのトリアージを行う必要があるため、悪用するのは非常に複雑です。また、メモリに書き込まれた値が連続して 3 回繰り返され、有効なペイロードを生成することが困難になります。この欠陥は、grub-2.12 より前の grub2 バージョンに影響を与えます。(CVE-2021-3695)

- PNG リーダーでの Huffman テーブルの処理中に、ヒープ領域外書き込みが発生する可能性があります。これにより、ヒープ空間でデータ破損が発生する可能性があります。攻撃者が破損した Huffman エントリのエンコーディングおよび配置を制御して、任意のコードの実行やセキュアブートの回避などの結果を達成するのが非常に複雑であるため、機密性、整合性、可用性への影響については、重要度低と見なされる可能性があります。この欠陥は、grub-2.12 より前の grub2 バージョンに影響を与えます。(CVE-2021-3696)

- 細工された JPEG 画像により、JPEG リーダーがデータポインターをアンダーフローさせ、ユーザー制御のデータをヒープに書き込めるようにする可能性があります。攻撃者が成功するには、ヒープレイアウトに対して何らかのトリアージを行い、悪意のあるフォーマットとペイロードで画像を作成する必要があります。この脆弱性により、データ破損や最終的なコードの実行やセキュアブート回避につながる可能性があります。この欠陥は、grub-2.12 より前の grub2 バージョンに影響を与えます。(CVE-2021-3697)

- grub2: grub_net_recv_ip4_packets の整数アンダーフロー (CVE-2022-28733)

- grub2: 分割された HTTP ヘッダーを処理する際の領域外書き込み (CVE-2022-28734)

- grub2: grub_cmd_chainloader() のメモリ解放後使用 (use-after-free) (CVE-2022-28736)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://bugzilla.suse.com/1191184

https://bugzilla.suse.com/1191185

https://bugzilla.suse.com/1191186

https://bugzilla.suse.com/1193282

https://bugzilla.suse.com/1198460

https://bugzilla.suse.com/1198493

https://bugzilla.suse.com/1198496

https://bugzilla.suse.com/1198581

https://www.suse.com/security/cve/CVE-2021-3695

https://www.suse.com/security/cve/CVE-2021-3696

https://www.suse.com/security/cve/CVE-2021-3697

https://www.suse.com/security/cve/CVE-2022-28733

https://www.suse.com/security/cve/CVE-2022-28734

https://www.suse.com/security/cve/CVE-2022-28736

http://www.nessus.org/u?b9bda300

プラグインの詳細

深刻度: High

ID: 162131

ファイル名: suse_SU-2022-2036-1.nasl

バージョン: 1.8

タイプ: local

エージェント: unix

公開日: 2022/6/11

更新日: 2024/1/18

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.9

Temporal Score: 5.1

ベクトル: CVSS2#AV:L/AC:M/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2021-3696

CVSS v3

リスクファクター: High

Base Score: 8.1

Temporal Score: 7.1

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2022-28733

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:grub2, p-cpe:/a:novell:suse_linux:grub2-arm64-efi, p-cpe:/a:novell:suse_linux:grub2-i386-pc, p-cpe:/a:novell:suse_linux:grub2-powerpc-ieee1275, p-cpe:/a:novell:suse_linux:grub2-s390x-emu, p-cpe:/a:novell:suse_linux:grub2-snapper-plugin, p-cpe:/a:novell:suse_linux:grub2-systemd-sleep-plugin, p-cpe:/a:novell:suse_linux:grub2-x86_64-efi, p-cpe:/a:novell:suse_linux:grub2-x86_64-xen, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/6/10

脆弱性公開日: 2022/6/16

参照情報

CVE: CVE-2021-3695, CVE-2021-3696, CVE-2021-3697, CVE-2022-28733, CVE-2022-28734, CVE-2022-28736

SuSE: SUSE-SU-2022:2036-1