Apache Airflow < 1.10.11 の複数の脆弱性

critical Nessus プラグイン ID 162136

概要

リモートホストにインストールされているアプリケーションにはベンダー提供の更新がありません。

説明

Apache Airflow のバージョンは 1.10.11 より前です。そのため、以下を含む複数の脆弱性による影響を受けます:

- Apache Airflow バージョン 1.10.10 以前で問題が見つかりました。CeleryExecutor を使用する場合、攻撃者がブローカー (Redis、RabbitMQ) に直接接続できる場合、コマンドを注入して、celery worker が任意のコマンドを実行する可能性があります。(CVE-2020-11981)

-Apache Airflowバージョン 1.10.10 以前で問題が見つかりました。攻撃がブローカー (Redis、RabbitMQ) に直接接続できる場合、CeleryExecutor を使用すると、悪意のあるペイロードがブローカーに直接挿入され、ワーカーで逆シリアル化攻撃 (したがってリモートコードの実行) につながる可能性があります。(CVE-2020-11982)

-Apache Airflowバージョン 1.10.10 以前で問題が見つかりました。Airflow に同梱されている DAG の例の 1 つに、リモートコード / コマンドインジェクションの脆弱性が発見されました。これにより、認証されたユーザーが、(使用中の executor に応じて) airflow worker / scheduler を実行しているユーザーとして任意のコマンドを実行する可能性があります。config で load_examples = False を設定することですでにサンプルの例が無効になっている場合は、脆弱ではありません。(CVE-2020-11978)

- Airflow の実験的 API の以前のデフォルト設定は、認証なしですべての API リクエストを許可することでしたが、これにより、この事実を見落とすユーザーにセキュリティリスクが生じます。Airflow 1.10.11 から、デフォルトですべてのリクエストを拒否するようにデフォルトが変更され、https://airflow.apache.org/docs/1.10.11/security.html#api-authentication で文書化されています。注意 : この変更により、新規インストールの場合は修正されますが、既存のユーザーは、構成をデフォルト [api]auth_backend = airflow.api.auth.backend.deny_all に変更する必要があります。これは、更新ガイド :
https://github.com/apache/airflow/blob/1.10.11/UPDATING.md#experimental-api-will-deny-all-request-by-default に記載されています (CVE-2020-13927)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Apache Airflow バージョン 1.10.11 以降にアップグレードしてください。

関連情報

https://lists.apache.org/thread/cn57zwylxsnzjyjztwqxpmly0x9q5ljx

https://lists.apache.org/thread/mq1bpqf3ztg1nhyc5qbrjobfrzttwx1d

http://www.nessus.org/u?152f8770

プラグインの詳細

深刻度: Critical

ID: 162136

ファイル名: apache_airflow_1_10_11.nasl

バージョン: 1.2

タイプ: remote

ファミリー: Misc.

公開日: 2022/6/13

更新日: 2022/6/13

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2020-13927

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:apache:airflow

必要な KB アイテム: installed_sw/Apache Airflow

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2020/7/10

脆弱性公開日: 2020/7/13

CISAの既知の悪用日: 2022/7/18

参照情報

CVE: CVE-2020-9485, CVE-2020-11978, CVE-2020-11981, CVE-2020-11982, CVE-2020-11983, CVE-2020-13927