RHEL 9: java-1.8.0-openjdk (RHSA-2022: 5709)

high Nessus プラグイン ID 163452

概要

リモートの Red Hat ホストに 1 つ以上のセキュリティ更新プログラムがありません。

説明

リモート Redhat Enterprise Linux 9 ホストにインストールされているパッケージは、RHSA-2022: 5709 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- OpenJDK: クラスのコンパイルの問題 (Hotspot、8281859) (CVE-2022-21540)

- OpenJDK: MethodHandle.invokeBasic() の不適切な制限 (Hotspot、8281866) (CVE-2022-21541)

- OpenJDK: Xalan-J での整数切り捨ての問題 (JAXP, 8285407) (CVE-2022-34169)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://bugzilla.redhat.com/show_bug.cgi?id=2107958

http://www.nessus.org/u?92c90c4a

https://access.redhat.com/security/updates/classification/#important

https://access.redhat.com/errata/RHSA-2022:5709

https://bugzilla.redhat.com/show_bug.cgi?id=2084776

https://bugzilla.redhat.com/show_bug.cgi?id=2099916

https://bugzilla.redhat.com/show_bug.cgi?id=2107956

https://bugzilla.redhat.com/show_bug.cgi?id=2108540

https://bugzilla.redhat.com/show_bug.cgi?id=2108543

https://bugzilla.redhat.com/show_bug.cgi?id=2108554

プラグインの詳細

深刻度: High

ID: 163452

ファイル名: redhat-RHSA-2022-5709.nasl

バージョン: 1.11

タイプ: local

エージェント: unix

公開日: 2022/7/26

更新日: 2024/4/28

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: High

基本値: 7.8

現状値: 6.1

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS スコアのソース: CVE-2022-34169

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:enterprise_linux:9, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-demo, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-demo-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-demo-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-devel, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-devel-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-devel-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-headless, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-headless-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-headless-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-javadoc, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-javadoc-zip, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-src, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-src-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-1.8.0-openjdk-src-slowdebug

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/7/25

脆弱性公開日: 2022/7/19

参照情報

CVE: CVE-2022-21540, CVE-2022-21541, CVE-2022-34169

CWE: 192, 284, 402

RHSA: 2022:5709