SUSE SLED15 / SLES15 / openSUSE 15 セキュリティ更新: カーネル (SUSE-SU-2022:2549-1)

high Nessus プラグイン ID 163482

Language:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLED15 / SLES15 / openSUSE 15 ホストには、SUSE-SU-2022:2549-1 のアドバイザリに記載されている複数の脆弱性の影響を受けるパッケージがインストールされています。

- 一部の AMD CPU は、無条件の直接分岐を超えて一時的に実行され、データ漏洩を引き起こす可能性があります。(CVE-2021-26341)

- ユーザーがミラーリング (NFS によるファイルのレプリケーション) を使用する方法に、Linux カーネル NFS サブシステムのメモリ領域外書き込みの欠陥 (1 または 2 バイトのメモリ) が見つかりました。NFS マウントにアクセスできるユーザーが、この欠陥を利用して、システムをクラッシュさせ、システム上で権限を昇格する可能性があります。(CVE-2021-4157)

- テーブルの混乱サイズが小さいため、net/ipv4/tcp.c の TCP ソースポート生成アルゴリズムにメモリ漏洩の問題が見つかりました。この欠陥により、攻撃者が情報を漏洩する可能性があり、サービス拒否の問題を引き起こす可能性があります。(CVE-2022-1012)

- Linux カーネルの Atheros ワイヤレスアダプタードライバーに、ユーザーが ath9k_htc_wait_for_target 関数を強制的に入力メッセージで失敗させる方法で、メモリ解放後使用 (Use-After-Free) の欠陥が見つかりました。この欠陥によりローカルユーザーがクラッシュさせたり、システムで自分の権限を昇格させたりする可能性があります。(CVE-2022-1679)

- lg-probe と hid-lg.c およびその他の USB HID ファイルの関連関数で、不適切な入力検証による、領域外読み取りの可能性があります。これにより、悪意ある USB HID デバイスがプラグインされていた場合、追加の実行権限が不要になり、ローカル情報漏洩が引き起こされる可能性があります。悪用はユーザーの操作を必要としません。製品: Android。バージョン: Android カーネル。Android ID: A-188677105。参照: Upstream カーネル (CVE-2022-20132)

- igmp.c の ip_check_mc_rcu で、不適切なロックによるメモリ解放後使用 (Use After Free) が発生する可能性があります。これにより、追加の実行権限が不要になり、inet ソケットの開閉時にローカルで権限が昇格される可能性があります。悪用はユーザーの操作を必要としません。製品: Android。バージョン: Android カーネル。Android ID: A-112551163。参照: Upstream カーネル (CVE-2022-20141)

- sock.c の lock_sock_nested では、競合状態によるメモリ解放後使用 (Use-After-Free) の可能性があります。これにより、システム実行権限が必要なローカルでの権限昇格が引き起こされる可能性があります。悪用はユーザーの操作を必要としません。製品: Android。バージョン: Android カーネル。Android ID: A-174846563。参照: Upstream カーネル (CVE-2022-20154)

- 戻り命令に対する誤ってトレーニングされた分岐予測により、特定のマイクロアーキテクチャ依存の条件下で、任意の投機的コードが実行される可能性があります。(CVE-2022-29900)

- Intel マイクロプロセッサー第 6 世代から第 8 世代は、新しい Spectre バリアントの影響を受け、カーネルでの retpoline 緩和策をバイパスし、任意のデータを漏洩することが可能です。権限のないユーザーアクセス権を持つ攻撃者が、リターン命令をハイジャックして、特定のマイクロアーキテクチャ依存の条件下で、任意の投機的コードを実行する可能性があります。(CVE-2022-29901)

- 5.17.6より前の Linux カーネルの drivers/block/floppy.c は、サービス拒否に対して脆弱です。これは、raw_cmd_ioctl 関数で raw_cmd を解放した後に同時使用によるメモリ解放後使用 (Use-After-Free) の欠陥が原因です。
(CVE-2022-33981)

- 5.18.9 までの Linux カーネルで問題が発見されました。ローカルの攻撃者が nft_set_elem_init の型の取り違え (バッファオーバーフローを引き起こす) バグを利用して、権限を昇格させる可能性があります。これは CVE-2022-32250とは別の脆弱性です。(攻撃者は root アクセス権を取得できますが、CAP_NET_ADMIN アクセス権を取得するには権限のないユーザーの名前空間で開始する必要があります。) これは net/netfilter/nf_tables_api.c の nft_setelem_parse_data で修正できます。(CVE-2022-34918)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://bugzilla.suse.com/1065729

https://bugzilla.suse.com/1179195

https://bugzilla.suse.com/1180814

https://bugzilla.suse.com/1184924

https://bugzilla.suse.com/1185762

https://bugzilla.suse.com/1192761

https://bugzilla.suse.com/1193629

https://bugzilla.suse.com/1194013

https://bugzilla.suse.com/1195504

https://bugzilla.suse.com/1195775

https://bugzilla.suse.com/1196901

https://bugzilla.suse.com/1197362

https://bugzilla.suse.com/1197754

https://bugzilla.suse.com/1198020

https://bugzilla.suse.com/1198924

https://bugzilla.suse.com/1199482

https://bugzilla.suse.com/1199487

https://bugzilla.suse.com/1199489

https://bugzilla.suse.com/1199657

https://bugzilla.suse.com/1200217

https://bugzilla.suse.com/1200263

https://bugzilla.suse.com/1200343

https://bugzilla.suse.com/1200442

https://bugzilla.suse.com/1200571

https://bugzilla.suse.com/1200599

https://bugzilla.suse.com/1200600

https://bugzilla.suse.com/1200604

https://bugzilla.suse.com/1200605

https://bugzilla.suse.com/1200608

https://bugzilla.suse.com/1200619

https://bugzilla.suse.com/1200622

https://bugzilla.suse.com/1200692

https://bugzilla.suse.com/1200806

https://bugzilla.suse.com/1200807

https://bugzilla.suse.com/1200809

https://bugzilla.suse.com/1200810

https://bugzilla.suse.com/1200813

https://bugzilla.suse.com/1200816

https://bugzilla.suse.com/1200820

https://bugzilla.suse.com/1200821

https://bugzilla.suse.com/1200822

https://bugzilla.suse.com/1200825

https://bugzilla.suse.com/1200828

https://bugzilla.suse.com/1200829

https://bugzilla.suse.com/1200925

https://bugzilla.suse.com/1201050

https://bugzilla.suse.com/1201080

https://bugzilla.suse.com/1201143

https://bugzilla.suse.com/1201147

https://bugzilla.suse.com/1201149

https://bugzilla.suse.com/1201160

https://bugzilla.suse.com/1201171

https://bugzilla.suse.com/1201177

https://bugzilla.suse.com/1201193

https://bugzilla.suse.com/1201222

https://bugzilla.suse.com/1201644

https://bugzilla.suse.com/1201664

https://bugzilla.suse.com/1201672

https://bugzilla.suse.com/1201673

https://bugzilla.suse.com/1201676

https://www.suse.com/security/cve/CVE-2021-26341

https://www.suse.com/security/cve/CVE-2021-4157

https://www.suse.com/security/cve/CVE-2022-1012

https://www.suse.com/security/cve/CVE-2022-1679

https://www.suse.com/security/cve/CVE-2022-20132

https://www.suse.com/security/cve/CVE-2022-20141

https://www.suse.com/security/cve/CVE-2022-20154

https://www.suse.com/security/cve/CVE-2022-29900

https://www.suse.com/security/cve/CVE-2022-29901

https://www.suse.com/security/cve/CVE-2022-33981

https://www.suse.com/security/cve/CVE-2022-34918

http://www.nessus.org/u?8ab27e59

プラグインの詳細

深刻度: High

ID: 163482

ファイル名: suse_SU-2022-2549-1.nasl

バージョン: 1.14

タイプ: local

エージェント: unix

公開日: 2022/7/27

更新日: 2023/7/13

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Critical

スコア: 9.7

CVSS v2

リスクファクター: High

Base Score: 7.4

Temporal Score: 6.4

ベクトル: CVSS2#AV:A/AC:M/Au:S/C:C/I:C/A:C

CVSS スコアのソース: CVE-2021-4157

CVSS v3

リスクファクター: High

Base Score: 8.2

Temporal Score: 7.8

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:H

現状ベクトル: CVSS:3.0/E:H/RL:O/RC:C

CVSS スコアのソース: CVE-2022-1012

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:kernel-livepatch-5_3_18-150300_59_87-default, p-cpe:/a:novell:suse_linux:kernel-macros, p-cpe:/a:novell:suse_linux:kernel-obs-build, p-cpe:/a:novell:suse_linux:kernel-preempt, p-cpe:/a:novell:suse_linux:kernel-preempt-devel, p-cpe:/a:novell:suse_linux:kernel-preempt-extra, p-cpe:/a:novell:suse_linux:kernel-source, p-cpe:/a:novell:suse_linux:kernel-syms, p-cpe:/a:novell:suse_linux:kernel-zfcpdump, p-cpe:/a:novell:suse_linux:ocfs2-kmp-default, p-cpe:/a:novell:suse_linux:reiserfs-kmp-default, cpe:/o:novell:suse_linux:15, p-cpe:/a:novell:suse_linux:cluster-md-kmp-default, p-cpe:/a:novell:suse_linux:dlm-kmp-default, p-cpe:/a:novell:suse_linux:gfs2-kmp-default, p-cpe:/a:novell:suse_linux:kernel-64kb, p-cpe:/a:novell:suse_linux:kernel-64kb-devel, p-cpe:/a:novell:suse_linux:kernel-default, p-cpe:/a:novell:suse_linux:kernel-default-base, p-cpe:/a:novell:suse_linux:kernel-default-devel, p-cpe:/a:novell:suse_linux:kernel-default-extra, p-cpe:/a:novell:suse_linux:kernel-default-livepatch, p-cpe:/a:novell:suse_linux:kernel-default-livepatch-devel, p-cpe:/a:novell:suse_linux:kernel-devel

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/7/26

脆弱性公開日: 2021/9/30

エクスプロイト可能

Core Impact

Metasploit (Netfilter nft_set_elem_init Heap Overflow Privilege Escalation)

参照情報

CVE: CVE-2021-26341, CVE-2021-4157, CVE-2022-1012, CVE-2022-1679, CVE-2022-20132, CVE-2022-20141, CVE-2022-20154, CVE-2022-29900, CVE-2022-29901, CVE-2022-33981, CVE-2022-34918

SuSE: SUSE-SU-2022:2549-1