GitLab 12.5 < 15.0.5 / 15.1 < 15.1.4 / 15.2 < 15.2.1 不適切な認証

medium Nessus プラグイン ID 163836

概要

リモート Web サーバーで実行されているソース管理アプリケーションは、不適切な認証の脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートの Web サーバーで実行されている GitLab のインスタンスは 15.0.5 より前の 12.5、15.1.4 より前の 15.1、15.2.1 より前の 15.2 です。したがって、不適切な認証の脆弱性の影響を受け、GitLab が特定の条件下で Grafana API で適切な認証を行っていなかったため、認証されていないユーザーがパストラバーサルの脆弱性を通じてクエリを実行する可能性があります。

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

GitLab バージョン 15.0.5、15.1.4、15.2.1 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?d88e3440

プラグインの詳細

深刻度: Medium

ID: 163836

ファイル名: gitlab_cve-2022-2531.nasl

バージョン: 1.5

タイプ: combined

エージェント: unix

ファミリー: CGI abuses

公開日: 2022/8/4

更新日: 2022/8/30

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 2.2

CVSS v2

リスクファクター: Medium

Base Score: 5

Temporal Score: 3.7

ベクトル: AV:N/AC:L/Au:N/C:P/I:N/A:N

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-2531

CVSS v3

リスクファクター: Medium

Base Score: 5.3

Temporal Score: 4.6

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:gitlab:gitlab

必要な KB アイテム: installed_sw/GitLab

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/7/28

脆弱性公開日: 2022/7/28

参照情報

CVE: CVE-2022-2531

IAVA: 2022-A-0302-S