Adobe Reader < 17.012.30262/ 20.005.30381/ 22.002.20191複数の脆弱性 (APSB22-39) (macOS)

high Nessus プラグイン ID 163956

概要

リモートのmacOSホストにインストールされているAdobe Readerのバージョンは、複数の脆弱性の影響を受けます。

説明

リモートのmacOSホストにインストールされているAdobe Readerのバージョンは、17.012.30262以前、20.005.30381以前、または22.002.20191以前です。したがって、複数の脆弱性の影響を受けます。

- Acrobat Reader DC バージョン 20.001.20085(以前)、20.005.3031x (以前) および 17.012.30205(以前) は、メモリ解放後使用 (Use-After-Free) の脆弱性の影響を受け、現在のユーザーのコンテキストで任意コード実行に至る可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-24102, CVE-2022-24103, CVE-2022-24104)

- Acrobat Pro DC バージョン 22.001.2011x(以前)、20.005.3033x (以前) および 17.012.3022x(以前) は、メモリ解放後使用 (Use-After-Free) の脆弱性の影響を受け、秘密メモリーの漏洩を引き起こす可能性があります。
攻撃者がこの脆弱性を利用し、ASLRのような緩和策をバイパスする可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-28837)

- Acrobat Acrobat Pro DC バージョン 22.001.2011x(以前)、20.005.3033x (以前) および 17.012.3022x(以前) は、メモリ解放後使用 (Use-After-Free) の脆弱性の影響を受け、現在のユーザーのコンテキストで任意コード実行に至る可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-28838)

- Acrobat Reader バージョン22.001.20142 (およびそれ以前)、20.005.30334 (およびそれ以前)、そして20.005.30334 (およびそれ以前) は、領域外読み取りの脆弱性の影響を受け、秘密メモリーの漏洩を引き起こす可能性があります。攻撃者がこの脆弱性を利用し、ASLRのような緩和策をバイパスする可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-35669)

- 任意のコード実行を引き起こす可能性があるメモリ解放後使用 (Use After Free) (CWE-416) (CVE-2022-35665)

- 任意のコード実行を引き起こす可能性がある不適切な入力検証 (CWE-20) (CVE-2022-35666)

- 任意のコード実行を引き起こす可能性がある領域外書き込み (CWE-787) (CVE-2022-35667)

- メモリリークを引き起こす可能性がある不適切な入力検証 (CWE-20) (CVE-2022-35668)

- メモリリークを引き起こす可能性があるメモリ解放後使用 (Use After Free) (CWE-416) (CVE-2022-35670)

- 領域外読み取り (CWE-125) によってメモリ漏洩が発生する可能性があります (CVE-2022-35671、CVE-2022-35678)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Adobe Reader バージョン 17.012.30262/20.005.30381/22.002.20191 またはそれ以降にアップグレードしてください。

関連情報

https://helpx.adobe.com/security/products/acrobat/apsb22-39.html

プラグインの詳細

深刻度: High

ID: 163956

ファイル名: macos_adobe_reader_apsb22-39.nasl

バージョン: 1.4

タイプ: local

エージェント: macosx

公開日: 2022/8/9

更新日: 2022/10/18

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 9.3

Temporal Score: 6.9

ベクトル: AV:N/AC:M/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-28838

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:adobe:acrobat_reader

必要な KB アイテム: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Reader

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/8/9

脆弱性公開日: 2022/4/12

参照情報

CVE: CVE-2022-35665, CVE-2022-35666, CVE-2022-35667, CVE-2022-35668, CVE-2022-35670, CVE-2022-35671, CVE-2022-35678

IAVA: 2022-A-0323-S

CWE: 20, 125, 416, 787