Nutanix AOS : Multiple Vulnerabilities (NXSA-AOS-6.0.1)

critical Nessus プラグイン ID 164614

概要

Nutanix AOS ホストは、複数の脆弱性の影響を受けます。

説明

リモートホストにインストールされている AOS のバージョンは、6.0.1 より前です。したがって、NXSA-AOS-6.0.1 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

-バージョン26.20.100.7212より前、およびLinuxカーネルバージョン5.5より前の、Intel(R) Graphics Drivers for Windows *の一部のファームウェアにおける整数オーバーフローにより、特権ユーザーがローカルアクセスを介して、権限昇格を有効化する可能性があります。(CVE-2020-12362)

- バージョン26.20.100.7212より前、およびLinuxカーネルバージョン5.5より前の、一部のIntel(R) Graphics Drivers for Windows *の入力検証が不適切なため、特権ユーザーがローカルアクセスを介して、サービス拒否を引き起こす可能性があります。(CVE-2020-12363)  

- バージョン26.20.100.7212より前、およびLinuxカーネルバージョン5.5より前の、一部のIntel(R) Graphics Drivers for Windows *のNULL ポインターリファレンスのため、特権ユーザーがローカルアクセスを介して、サービス拒否を引き起こす可能性があります。(CVE-2020-12364)

-5.11.8より前のLinuxカーネルで問題が発見されました。kernel/bpf/verifier.cは、ポインター計算に対して望ましくない領域外の投機を実行し、これによって、サイドチャネル攻撃が引き起こされる可能性があります。この攻撃ではSpectreの緩和策が無効にされ、カーネルメモリから機密情報が取得されます(別名CID-f232326f6966)。これは、ptr_limitを定義しないポインタータイプに影響します。(CVE-2020-27170)

-5.5.2までのLinuxカーネルで、drivers/tty/n_ttyのn_tty_receive_buf_common関数にメモリ解放後使用(Use-After-Free)の脆弱性があります。(CVE-2020-8648)

- 3.7.2より前のバージョンのNettleに欠陥が見つかりました。いくつかのNettle署名認証関数(GOST DSA、EDDSA&ECDSA)により、楕円曲線暗号化ポイント(ECC)の乗算関数が範囲外のスケーラーで呼び出され、結果が不正確になる可能性があります。この欠陥により、攻撃者が無効な署名を強制し、アサーションの失敗または検証を引き起こす可能性があります。この脆弱性が最大の脅威となるのは、機密性と整合性、ならびにシステムの可用性です。(CVE-2021-20305)

- Oracle Java SE の Java SE、Java SE Embedded、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: ライブラリ)。サポートされているバージョンで影響を受けるのは、Java SE: 7u291、8u281、11.0.10、16;
Java SE Embedded: 8u281。Oracle GraalVM Enterprise Edition:19.3.5、20.3.1.2、および 21.0.0.2で構成されています。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Java SE、Java SE Embedded、Oracle GraalVM Enterprise Editionを侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータやJava SE、Java SE Embedded、Oracle GraalVM Enterprise Editionがアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があります。注: この脆弱性は、信頼できないコード(インターネットからのコードなど)を読み込んで実行し、セキュリティをJavaサンドボックスに依存するJavaデプロイメントが対象です。これは、指定されたコンポーネントのAPIに信頼できないデータを供給することでも悪用される可能性があります。CVSS 3.1ベーススコア5.9(整合性への影響) CVSS Vector:
(CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N)。(CVE-2021-2161)

- Oracle Java SEのJava SE、Java SE Embedded、Oracle GraalVM Enterprise Edition製品の脆弱性(コンポーネント: ライブラリ)。サポートされているバージョンで影響を受けるのは、Java SE: 7u291、8u281、11.0.10、16;
Java SE Embedded: 8u281。Oracle GraalVM Enterprise Edition:19.3.5、20.3.1.2、および 21.0.0.2で構成されています。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Java SE、Java SE Embedded、Oracle GraalVM Enterprise Editionを侵害する可能性があります。この攻撃が成功するには、攻撃者以外の人物の関与が必要です。この脆弱性に対する攻撃が成功すると、重要なデータやJava SE、Java SE Embedded、Oracle GraalVM Enterprise Editionがアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があります。注: この脆弱性は、信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティをJavaサンドボックスに依存するJavaデプロイメントが対象です。CVSS 3.1ベーススコア5.3 (整合性への影響) CVSS Vector:
(CVSS:3.1/AV:N/AC:H/PR:N/UI:R/S:U/C:N/I:H/A:N)。(CVE-2021-2163)

- BIND 9.0.0 -> 9.11.29、9.12.0 -> 9.16.13、およびバージョン BIND 9.9.3-S1 -> 9.11.29-S1 および 9.16.8-S1 -> 9.16.13-S1 の BIND Supported Preview Edition、ならびに BIND 9.17 開発ブランチのリリースバージョン 9.17.0 -> 9.17.11 とともに、named の脆弱なバージョンが上記の欠陥を発生させるレコードのクエリを受け取ると、named プロセスがアサーションチェックの失敗により終了します。この脆弱性は、現在維持されているすべてのBIND 9ブランチ(9.11、9.11-S、9.16、9.16-S、9.17)およびBIND 9の他のすべてのバージョンに影響を与えます。(CVE-2021-25215)

- ISC DHCP 4.1-ESV-R1 -> 4.1-ESV-R16、ISC DHCP 4.4.0 -> 4.4.2(ISC DHCPのその他のブランチ(つまり、4.0.x4.3.xシリーズ以前のリリースおよびシリーズのリリース)はサポート終了(EOL)を超えており、ISCによるサポートが終了しています。検査から、これらのシリーズのリリースにも欠陥が存在することが明らかですが、脆弱性について公式にテストされていません)、欠陥をトリガーするリースの読み取り中に欠陥に遭遇した結果は、次のことに応じて異なります。影響を受けているコンポーネント(つまり、dhclient またはdhcpd)、このパッケージが32ビットまたは64ビットバイナリとしてビルドされたかどうか、dhclientのコンパイルするときに、コンパイラflag -fstack-protection-strongが使用されたかどうか、ISCは64ビットシステムでこのエラーを正常に再現していません。ただし、32ビットシステムでは、不適切なリースを読み取る際にdhclientのクラッシュを引き起こす可能性があります。これにより、DHCPクライアントプロセスが実行されていないため、影響を受けるシステムに対して、ネットワーク接続の問題を引き起こす可能性があります。dhcpdで、DHCPv4またはDHCPv6モードで実行した場合: dhcpdサーバーバイナリが32ビットアーキテクチャ用にビルドされており、さらに、-fstack-protection-strongフラグがコンパイラに指定された場合、dhcpdは、好ましくないリースを含むリースファイルの解析中に終了する可能性があり、クライアントへのサービスが提供されない可能性があります。さらに、問題のあるリースと、リース データベースでそれに続くリースが不適切に削除される可能性があります。dhcpdサーバーバイナリが64ビットアーキテクチャ用に構築された場合、または-fstack-protection-strongコンパイラフラグが指定されていない場合、クラッシュは発生しませんが、問題のあるリースとそれに続くリースが不適切に削除される可能性があります。(CVE-2021-25217)

- パッチ4.8.0までのGNU Screenのencoding.cにより、リモートの攻撃者が、サービス拒否(無効な書き込みアクセスおよびアプリケーションクラッシュ)を引き起こす、またはUTF-8文字シーケンスを介して、詳細不明の他の影響を与えることが可能です。(CVE-2021-26937)

- 2.66.6より前、および2.67.3より前の2.67.xのGNOME GLibで問題が発見されました。64ビットから32ビットへの暗黙のキャストが原因で、64ビットプラットフォームでg_bytes_new関数に整数オーバーフローがあります。オーバーフローにより、メモリ破損が発生する可能性があります。(CVE-2021-27219)

- 5.10.11 までの Linux カーネルで問題が発見されました。PI futexには、障害処理中にカーネルスタックのuse-after-freeがあり、ローカルユーザーがカーネル(別名CID-34b1a1ce1458)でコードを実行することが可能です。
(CVE-2021-3347)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Nutanix AOS ソフトウェアを推奨バージョンに更新してください。

関連情報

https://download.nutanix.com/advisories/NXSA-AOS-6-0-1.html

プラグインの詳細

深刻度: Critical

ID: 164614

ファイル名: nutanix_NXSA-AOS-6_0_1.nasl

バージョン: 1.2

タイプ: local

ファミリー: Misc.

公開日: 2022/9/1

更新日: 2022/9/1

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.5

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-26937

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:nutanix:aos:*:*:*:*:*:*:*:*

必要な KB アイテム: Host/Nutanix/Data/lts, Host/Nutanix/Data/Service, Host/Nutanix/Data/Version, Host/Nutanix/Data/arch

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/8/24

脆弱性公開日: 2020/2/6

参照情報

CVE: CVE-2020-8648, CVE-2021-3347, CVE-2021-26937, CVE-2021-27219, CVE-2020-12362, CVE-2020-12364, CVE-2020-12363, CVE-2020-27170, CVE-2021-20305, CVE-2021-2161, CVE-2021-2163, CVE-2021-25215, CVE-2021-25217