Microsoft Edge (chromium) < 105.0.1343.25の複数の脆弱性

high Nessus プラグイン ID 164638

概要

リモートホストに、複数の脆弱性の影響を受ける Web ブラウザがインストールされています。

説明

リモートの Windows ホストにインストールされている Microsoft Edge のバージョンは、105.0.1343.25 より前です。したがって、2022 年 9 月 1 日のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Network Service のメモリ解放後使用 (Use After Free)。(CVE-2022-3038)

- WebSQL のメモリ解放後使用 (Use After Free)。(CVE-2022-3039、CVE-2022-3041)

- Layout のメモリ解放後使用 (Use After Free)。(CVE-2022-3040)

- Site Isolation における不適切な実装。(CVE-2022-3044)

- V8 での信頼できない入力の不十分な検証。(CVE-2022-3045)

- ブラウザタグのメモリ解放後使用 (Use After Free)。(CVE-2022-3046)

- Extensions API における不十分なポリシー実施。(CVE-2022-3047)

- Pointer Lock における不適切な実装。(CVE-2022-3053)

- DevTools における不十分なポリシー実施。(CVE-2022-3054)

- パスワードでのメモリ解放後使用 (Use After Free)。(CVE-2022-3055)

- Content Security ポリシーでの不十分なポリシー実施。(CVE-2022-3056)

- iframe Sandbox における不適切な実装。(CVE-2022-3057)

- Sign-In Flow におけるメモリ解放後使用 (Use After Free)。(CVE-2022-3058)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Microsoft Edge をバージョン 105.0.1343.25以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?31d28038

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3038

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3039

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3040

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3041

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3044

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3045

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3046

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3047

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3053

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3054

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3055

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3056

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3057

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-3058

https://msrc.microsoft.com/update-guide/vulnerability/CVE-2022-38012

プラグインの詳細

深刻度: High

ID: 164638

ファイル名: microsoft_edge_chromium_105_0_1343_25.nasl

バージョン: 1.6

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2022/9/2

更新日: 2022/10/11

サポートされているセンサー: Frictionless Assessment Agent, Frictionless Assessment AWS, Frictionless Assessment Azure, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 8.1

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.8

ベクトル: AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-3058

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.9

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:microsoft:edge

必要な KB アイテム: installed_sw/Microsoft Edge (Chromium), SMB/Registry/Enumerated

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/9/1

脆弱性公開日: 2022/8/30

参照情報

CVE: CVE-2022-3038, CVE-2022-3039, CVE-2022-3040, CVE-2022-3041, CVE-2022-3044, CVE-2022-3045, CVE-2022-3046, CVE-2022-3047, CVE-2022-3053, CVE-2022-3054, CVE-2022-3055, CVE-2022-3056, CVE-2022-3057, CVE-2022-3058, CVE-2022-38012

IAVA: 2022-A-0361-S