Amazon Linux 2022 : (ALAS2022-2022-093)

low Nessus プラグイン ID 164762

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-093 のアドバイザリに記載されている脆弱性の影響を受けます。

- src/testcase.c: line 2334 の Solver * testcase_read(Pool *pool、FILE *fp、const char *testcase、Queue *job、char **resultp、int *resultflagsp関数を介した libsolv 2020-12-13 のバッファオーバーフローの脆弱性により、サービス拒否が発生する可能性があります (CVE-2021-3200)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

「dnf update --releasever=2022.0.20220628 libsolv」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-093.html

https://alas.aws.amazon.com/cve/html/CVE-2021-3200.html

プラグインの詳細

深刻度: Low

ID: 164762

ファイル名: al2022_ALAS2022-2022-093.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/9/6

更新日: 2022/9/6

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 1.4

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-3200

CVSS v3

リスクファクター: Low

Base Score: 3.3

Temporal Score: 2.9

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:libsolv, p-cpe:/a:amazon:linux:libsolv-debuginfo, p-cpe:/a:amazon:linux:libsolv-debugsource, p-cpe:/a:amazon:linux:libsolv-demo, p-cpe:/a:amazon:linux:libsolv-demo-debuginfo, p-cpe:/a:amazon:linux:libsolv-devel, p-cpe:/a:amazon:linux:libsolv-tools, p-cpe:/a:amazon:linux:libsolv-tools-debuginfo, p-cpe:/a:amazon:linux:perl-solv, p-cpe:/a:amazon:linux:perl-solv-debuginfo, p-cpe:/a:amazon:linux:python3-solv, p-cpe:/a:amazon:linux:python3-solv-debuginfo, p-cpe:/a:amazon:linux:ruby-solv, p-cpe:/a:amazon:linux:ruby-solv-debuginfo, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/6/28

脆弱性公開日: 2021/5/18

参照情報

CVE: CVE-2021-3200