Amazon Linux 2022 : (ALAS2022-2022-088)

medium Nessus プラグイン ID 164770

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-088 のアドバイザリに記載されている脆弱性の影響を受けます。

- containerd は、オープンソースのコンテナランタイムです。containerdのCRI実装にバグが見つかりました。コンテナ内部のプログラムにより、「ExecSync」APIの呼び出し中に、containerdデーモンがメモリを消費する可能性があります。これにより、containerdがコンピューターで利用可能なすべてのメモリを消費し、他の正当なワークロードに対するサービスを拒否する可能性があります。Kubernetesとcrictlはどちらも、containerdのCRI実装を使用するように構成できます。 「ExecSync」は、プローブを実行するとき、またはexec機能を介してプロセスを実行するときに使用される可能性があります。このバグは、containerd 1.6.6および1.5.13で修正されました。この問題を解決するには、ユーザーがこれらのバージョンに更新する必要があります。アップグレードできないユーザーは、信頼できるイメージとコマンドのみが使用されるようにする必要があります。(CVE-2022-31030)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

「dnf update --releasever=2022.0.20220518 containerd」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-088.html

https://alas.aws.amazon.com/cve/html/CVE-2022-31030.html

プラグインの詳細

深刻度: Medium

ID: 164770

ファイル名: al2022_ALAS2022-2022-088.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/9/6

更新日: 2022/9/6

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 4.4

CVSS v2

リスクファクター: Low

Base Score: 2.1

Temporal Score: 1.6

ベクトル: AV:L/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-31030

CVSS v3

リスクファクター: Medium

Base Score: 5.5

Temporal Score: 4.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:containerd, p-cpe:/a:amazon:linux:containerd-debuginfo, p-cpe:/a:amazon:linux:containerd-debugsource, p-cpe:/a:amazon:linux:containerd-stress, p-cpe:/a:amazon:linux:containerd-stress-debuginfo, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/6/6

脆弱性公開日: 2022/6/6

参照情報

CVE: CVE-2022-31030