Amazon Linux 2022 : (ALAS2022-2022-059)

high Nessus プラグイン ID 164776

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-059 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- アーカイブの抽出中に不適切なリンク解決の欠陥が発生し、アーカイブ外のファイルのモード、時間、アクセスコントロールリスト、フラグが変更される可能性があります。攻撃者が、悪意のあるアーカイブを被害者ユーザーに提供する可能性があります。被害者ユーザーは、アーカイブを抽出しようとする際に、この欠陥を発生させる可能性があります。ローカルの攻撃者がこの欠陥を利用して、システムでより多くの権限を取得する可能性があります。(CVE-2021-31566)

- libarchive 3.4.1 から 3.5.1 までの間、copy_string (do_uncompress_block および process_block から呼び出されます) にメモリ解放後使用 (Use-After-Free) があります。(CVE-2021-36976)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「dnf update --releasever=2022.0.20220504 libarchive」を実行して、お使いのシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-059.html

https://alas.aws.amazon.com/cve/html/CVE-2021-31566.html

https://alas.aws.amazon.com/cve/html/CVE-2021-36976.html

プラグインの詳細

深刻度: High

ID: 164776

ファイル名: al2022_ALAS2022-2022-059.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/9/7

更新日: 2022/9/7

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 4.3

Temporal Score: 3.2

ベクトル: AV:N/AC:M/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-36976

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2021-31566

脆弱性情報

CPE: p-cpe:/a:amazon:linux:bsdcat, p-cpe:/a:amazon:linux:bsdcat-debuginfo, p-cpe:/a:amazon:linux:bsdcpio, p-cpe:/a:amazon:linux:bsdcpio-debuginfo, p-cpe:/a:amazon:linux:bsdtar, p-cpe:/a:amazon:linux:bsdtar-debuginfo, p-cpe:/a:amazon:linux:libarchive, p-cpe:/a:amazon:linux:libarchive-debuginfo, p-cpe:/a:amazon:linux:libarchive-debugsource, p-cpe:/a:amazon:linux:libarchive-devel, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/5/4

脆弱性公開日: 2021/7/20

参照情報

CVE: CVE-2021-31566, CVE-2021-36976