Amazon Linux 2022 : (ALAS2022-2022-112)

high Nessus プラグイン ID 164786

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-112 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント : ホットスポット)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 7u343、8u333、11.0.15.1、17.0.3.1、18.0.1.1 と Oracle GraalVM Enterprise Edition:20.3.6、21.3.2、および 22.1.0です。容易に悪用できる脆弱性により、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition がアクセスできるデータのサブセットに、権限なしで読み取りアクセスが行われる可能性があります。
注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、指定されたコンポーネントで API を使用することによって (たとえば API にデータを提供する Web サービスを通して) 悪用される可能性もあります。CVSS 3.1 ベーススコア 5.3 (機密性に影響) CVSS Vector: (CVSS:3.1/AV:N/AC:L/PR:N/UI:N/S:U/C:L/I:N/A:N)。
(CVE-2022-21540)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: ホットスポット)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 7u343、8u333、11.0.15.1、17.0.3.1、18.0.1.1 と Oracle GraalVM Enterprise Edition:20.3.6、21.3.2、および 22.1.0です。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータや Oracle Java SE、Oracle GraalVM Enterprise Edition がアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、指定されたコンポーネントで API を使用することによって (たとえば API にデータを提供する Web サービスを通して) 悪用される可能性もあります。CVSS 3.1 ベーススコア 5.9 (整合性への影響 ) CVSS Vector:
(CVSS:3.1/AV:N/AC:H/PR:N/UI:N/S:U/C:N/I:H/A:N)。(CVE-2022-21541)

- Apache Xalan Java XSLT ライブラリは、悪意のある XSLT スタイルシートを処理する際に、整数切り捨ての問題に対して脆弱です。これは、内部 XSLTC コンパイラによって生成された Java クラスファイルを破損させ、任意の Java バイトコードを実行するために使用される可能性があります。Apache Xalan Java プロジェクトは休眠中であり、終了する予定です。この問題に対処する Apache Xalan Java の今後のリリースは期待されていません。注: Java ランタイム (OpenJDK など) には、Xalan の再パッケージされたコピーが含まれています。(CVE-2022-34169)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「dnf update --releasever=2022.0.20220719 java-11-amazon-corretto」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/cve/html/CVE-2022-21540.html

https://alas.aws.amazon.com/cve/html/CVE-2022-21541.html

https://alas.aws.amazon.com/cve/html/CVE-2022-34169.html

https://alas.aws.amazon.com/AL2022/ALAS-2022-112.html

プラグインの詳細

深刻度: High

ID: 164786

ファイル名: al2022_ALAS2022-2022-112.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/9/7

更新日: 2022/12/5

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: Medium

スコア: 6.1

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.1

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-34169

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-headless:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-javadoc:*:*:*:*:*:*:*, cpe:2.3:o:amazon:linux:2022:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-jmods:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/7/20

脆弱性公開日: 2022/7/19

参照情報

CVE: CVE-2022-34169, CVE-2022-21540, CVE-2022-21541