Wireshark 3.4.x < 3.4.16の脆弱性

high Nessus プラグイン ID 164838

概要

リモートのWindowsホストにインストールされているアプリケーションは、脆弱性の影響を受けます。

説明

リモートの Windows ホストにインストールされている Wireshark のバージョンは、3.4.16 より前です。したがって、wireshark-3.4.16 のアドバイザリに記載されている脆弱性の影響を受けます。

- F5 Ethernet Trailer ディセクタが、無限ループに陥る可能性があります。無効な形式のパケットをワイヤに注入するか、誰かに無効な形式のパケットトレースファイルを読み取らせることで、WiresharkがCPUリソースを過剰に消費する可能性があります。(wireshark-bug-18307)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

Wiresharkをバージョン3.4.16以降にアップグレードしてください。

関連情報

https://www.wireshark.org/docs/relnotes/wireshark-3.4.16.html

https://gitlab.com/wireshark/wireshark/-/issues/18307

https://www.wireshark.org/security/wnpa-sec-2022-06

プラグインの詳細

深刻度: High

ID: 164838

ファイル名: wireshark_3_4_16.nasl

バージョン: 1.3

タイプ: local

エージェント: windows

ファミリー: Windows

公開日: 2022/9/7

更新日: 2022/9/23

サポートされているセンサー: Frictionless Assessment Agent, Nessus Agent

脆弱性情報

CPE: cpe:/a:wireshark:wireshark

必要な KB アイテム: installed_sw/Wireshark, SMB/Registry/Enumerated

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/9/7

脆弱性公開日: 2022/9/7

参照情報

IAVB: 2022-B-0035