SUSE SLED15 / SLES15 / openSUSE 15 セキュリティ更新: webkit2gtk3 (SUSE-SU-2022:3488-1)

high Nessus プラグイン ID 165618

言語:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLED15 / SLES15 / openSUSE 15 ホストには、SUSE-SU-2022:3488-1 のアドバイザリに記載されている複数の脆弱性の影響を受けるパッケージがインストールされています。

- バッファオーバーフローの問題が、メモリ処理を改善することで対処されました。この問題は Safari 16、iOS 16、iOS 15.7および iPadOS 15.7で修正されています。悪意を持って細工された Web コンテンツを処理すると、任意のコードが実行される可能性があります。(CVE-2022-32886)

- 境界チェックを改善することによって領域外読み取りの問題に対処しました。この問題は Safari 16、iOS 16、iOS 15.7 および iPadOS 15.7 で修正されています。悪意を持って細工された Web コンテンツを処理すると、任意のコードが実行される可能性があります。(CVE-2022-32912)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://bugzilla.suse.com/1203530

http://www.nessus.org/u?860db88e

https://www.suse.com/security/cve/CVE-2022-32886

https://www.suse.com/security/cve/CVE-2022-32912

プラグインの詳細

深刻度: High

ID: 165618

ファイル名: suse_SU-2022-3488-1.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/10/2

更新日: 2023/1/20

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: High

スコア: 7.4

CVSS v2

リスクファクター: Critical

Base Score: 10

Temporal Score: 7.4

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-32912

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:o:novell:suse_linux:15:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:webkit2gtk-4_0-injected-bundles:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libjavascriptcoregtk-4_0-18:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libwebkit2gtk-4_0-37:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:typelib-1_0-javascriptcore-4_0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:typelib-1_0-webkit2-4_0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:typelib-1_0-webkit2webextension-4_0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libjavascriptcoregtk-5_0-0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:libwebkit2gtk-5_0-0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:typelib-1_0-javascriptcore-5_0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:typelib-1_0-webkit2-5_0:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:webkit2gtk-5_0-injected-bundles:*:*:*:*:*:*:*, p-cpe:2.3:a:novell:suse_linux:webkit2gtk3-soup2-devel:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/10/1

脆弱性公開日: 2022/9/12

参照情報

CVE: CVE-2022-32886, CVE-2022-32912

SuSE: SUSE-SU-2022:3488-1