Adobe Reader < 20.005.30407 / 22.003.20258 複数の脆弱性 (APSB22-46) (macOS)

high Nessus プラグイン ID 166044

概要

リモートの macOS ホストにインストールされている Adobe Reader のバージョンは、複数の脆弱性の影響を受けます。

説明

リモートの macOS ホストにインストールされている Adobe Readerのバージョンは、20.005.30407 または 22.003.20258 より前です。したがって、複数の脆弱性の影響を受けます。

- Adobe Acrobat Reader バージョン 22.002.20212 以前および 20.005.30381 以前は、Null ポインターデリファレンスの脆弱性の影響を受けます。認証されていない攻撃者がこの脆弱性を利用し、現在のユーザーのコンテキストでアプリケーションのサービス拒否を引き起こす可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-35691)

- Adobe Acrobat Reader バージョン 22.002.20212(以前) および 20.005.30381(以前) は、メモリ解放後使用 (Use-After-Free) の脆弱性の影響を受け、秘密メモリーの漏洩を引き起こす可能性があります。攻撃者がこの脆弱性を利用し、ASLR のような緩和策をバイパスする可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-38437)

- Adobe Acrobat Reader バージョン 22.002.20212 以前および 20.005.30381 以前は、領域外読み取りの脆弱性の影響を受け、秘密メモリの漏洩を引き起こす可能性があります。攻撃者がこの脆弱性を利用し、ASLR のような緩和策をバイパスする可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-38449、CVE-2022-42342)

- Adobe Acrobat Reader バージョン 22.002.20212 以前および 20.005.30381 以前はスタックベースのバッファオーバーフローの脆弱性の影響を受け、結果として、現在のユーザーのコンテキストで任意コード実行が発生する可能性があります。この問題を悪用するにはユーザーの操作が必要で、被害者が悪意のあるファイルを開く必要があります。(CVE-2022-38450、CVE-2022-42339)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Adobe Reader をバージョン 20.005.30407/ 22.003.20258以降にアップグレードしてください。

参考資料

https://helpx.adobe.com/security/products/acrobat/apsb22-46.html

プラグインの詳細

深刻度: High

ID: 166044

ファイル名: macos_adobe_reader_apsb22-46.nasl

バージョン: 1.7

タイプ: local

エージェント: macosx

公開日: 2022/10/11

更新日: 2023/3/23

サポートされているセンサー: Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.2

Temporal Score: 5.3

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2022-42339

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:adobe:acrobat_reader

必要な KB アイテム: Host/local_checks_enabled, Host/MacOSX/Version, installed_sw/Adobe Reader

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/10/11

脆弱性公開日: 2022/4/12

参照情報

CVE: CVE-2022-35691, CVE-2022-38437, CVE-2022-38449, CVE-2022-38450, CVE-2022-42339, CVE-2022-42342

CWE: 121, 125, 416, 476

IAVA: 2022-A-0418-S