Amazon Linux 2022 : (ALAS2022-2022-154)

critical Nessus プラグイン ID 166354

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-154 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- FreeType コミット 1e2eb65048f75c64b68708efed6ce904c31f3b2f に、関数 sfnt_init_face によるヒープバッファオーバーフローが含まれていることが発見されました。(CVE-2022-27404)

- FreeType コミット 53dfdcd8198d2b3201a23c4bad9190519ba918db に、関数 FNT_Size_Request を介したセグメンテーション違反が含まれていることが発見されました。(CVE-2022-27405)

- FreeType コミット 22a0cccb4d9d002f33c1ba7a4b36812c7d4f46b5 で、関数 FT_Request_Size によるセグメンテーション違反が含まれていることが検出されました。(CVE-2022-27406)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「dnf update freetype --releasever=2022.0.20221019」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-154.html

https://alas.aws.amazon.com/cve/html/CVE-2022-27404.html

https://alas.aws.amazon.com/cve/html/CVE-2022-27405.html

https://alas.aws.amazon.com/cve/html/CVE-2022-27406.html

プラグインの詳細

深刻度: Critical

ID: 166354

ファイル名: al2022_ALAS2022-2022-154.nasl

バージョン: 1.5

タイプ: local

エージェント: unix

公開日: 2022/10/20

更新日: 2022/12/5

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.5

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:H/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-27404

CVSS v3

リスクファクター: Critical

Base Score: 9.8

Temporal Score: 9.4

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:H/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:freetype, p-cpe:/a:amazon:linux:freetype-debuginfo, p-cpe:/a:amazon:linux:freetype-debugsource, p-cpe:/a:amazon:linux:freetype-demos, p-cpe:/a:amazon:linux:freetype-demos-debuginfo, p-cpe:/a:amazon:linux:freetype-devel, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/10/17

脆弱性公開日: 2022/4/22

CISAの既知の悪用日: 2021/11/17

参照情報

CVE: CVE-2020-15999, CVE-2022-27404, CVE-2022-27405, CVE-2022-27406

CEA-ID: CEA-2020-0124