Amazon Linux 2022 : (ALAS2022-2022-153)

high Nessus プラグイン ID 166357

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-153 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: JGSS)。サポートされているバージョンで影響を受けるのは、Oracle Java SE:17.0.4.1、19; Oracle GraalVM Enterprise Edition:21.3.3および22.2.0です。容易に悪用できる脆弱性により、認証されていない攻撃者が Kerberos を使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。
この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition がアクセスできるデータの一部に権限なしで更新アクセス、挿入アクセス、または削除アクセスが行われる可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、指定されたコンポーネントで API を使用することによって (例えば API にデータを提供する Web サービスを通して) 悪用される可能性もあります。(CVE-2022-21618)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: セキュリティ)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 8u341、8u345-perf、11.0.16.1、17.0.4.1、19; Oracle GraalVM Enterprise Edition:20.3.7、21.3.3、および 22.2.0です。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition がアクセスできるデータの一部に権限なしで更新アクセス、挿入アクセス、または削除アクセスが行われる可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、指定されたコンポーネントで API を使用することによって (例えば API にデータを提供する Web サービスを通して) 悪用される可能性もあります。(CVE-2022-21619)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: JNDI)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 8u341、8u345-perf、11.0.16.1、17.0.4.1、19; Oracle GraalVM Enterprise Edition:20.3.7、21.3.3、および 22.2.0です。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition がアクセスできるデータの一部に権限なしで更新アクセス、挿入アクセス、または削除アクセスが行われる可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、指定されたコンポーネントで API を使用することによって (例えば API にデータを提供する Web サービスを通して) 悪用される可能性もあります。(CVE-2022-21624)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: セキュリティ)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 8u341、8u345-perf、11.0.16.1; Oracle GraalVM Enterprise Edition:20.3.7、21.3.3、および 22.2.0です。容易に悪用できる脆弱性により、認証されていない攻撃者が HTTPS を使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition の部分的なサービス拒否 (部分的 DOS) が権限なしで引き起こされる可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、指定されたコンポーネントで API を使用することによって (例えば API にデータを提供する Web サービスを通して) 悪用される可能性もあります。
(CVE-2022-21626)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: 軽量 HTTP サーバー)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 8u341、8u345-perf、11.0.16.1、17.0.4.1、19; Oracle GraalVM Enterprise Edition:20.3.7、21.3.3、および 22.2.0です。容易に悪用できる脆弱性により、認証されていない攻撃者が HTTP を使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition の部分的なサービス拒否 (部分的 DOS) が権限なしで引き起こされる可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、通常サーバーで信頼できるコード (管理者がインストールしたコードなど) のみを読み込んで実行する Java デプロイメントを対象としていません。(CVE-2022-21628)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: ネットワーキング)。サポートされているバージョンで影響を受けるのは、Oracle Java SE:11.0.16.1、17.0.4.1、19;
Oracle GraalVM Enterprise Edition:20.3.7、21.3.3、および 22.2.0です。悪用が難しい脆弱性ですが、認証されていない攻撃者が HTTP を使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、Oracle Java SE、Oracle GraalVM Enterprise Edition がアクセスできるデータの一部に権限なしで更新アクセス、挿入アクセス、または削除アクセスが行われる可能性があります。注: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、通常サーバーで信頼できるコード (管理者がインストールしたコードなど) のみを読み込んで実行する Java デプロイメントを対象としていません。(CVE-2022-39399)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「dnf update java-11-amazon-corretto --releasever=2022.0.20221019」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/cve/html/CVE-2022-21618.html

https://alas.aws.amazon.com/cve/html/CVE-2022-21619.html

https://alas.aws.amazon.com/cve/html/CVE-2022-21624.html

https://alas.aws.amazon.com/cve/html/CVE-2022-21626.html

https://alas.aws.amazon.com/cve/html/CVE-2022-21628.html

https://alas.aws.amazon.com/cve/html/CVE-2022-39399.html

https://alas.aws.amazon.com/AL2022/ALAS-2022-153.html

プラグインの詳細

深刻度: High

ID: 166357

ファイル名: al2022_ALAS2022-2022-153.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/10/21

更新日: 2022/11/28

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment

リスク情報

VPR

リスクファクター: Medium

スコア: 6.1

CVSS v2

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.1

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

現状ベクトル: CVSS2#E:POC/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-34169

CVSS v3

リスクファクター: High

Base Score: 7.5

Temporal Score: 6.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-headless:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-javadoc:*:*:*:*:*:*:*, cpe:2.3:o:amazon:linux:2022:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-devel:*:*:*:*:*:*:*, p-cpe:2.3:a:amazon:linux:java-11-amazon-corretto-jmods:*:*:*:*:*:*:*

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/10/17

脆弱性公開日: 2022/10/17

参照情報

CVE: CVE-2022-34169, CVE-2022-21540, CVE-2022-21541, CVE-2022-21618, CVE-2022-21619, CVE-2022-21624, CVE-2022-21628, CVE-2022-39399, CVE-2022-21626