Amazon Linux 2:vim (ALAS-2022-1868)

high Nessus プラグイン ID 166395

概要

リモートの Amazon Linux 2 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2-2022-1868 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- 9.0 より前の GitHub リポジトリ vim/vim における領域外読み取り。(CVE-2022-2257、CVE-2022-2286、CVE-2022-2287)

- 9.0 より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-2264、CVE-2022-2284)

- 9.0 より前の GitHub リポジトリ vim/vim における整数オーバーフローまたはラップアラウンド。(CVE-2022-2285)

- 9.0より前の GitHub リポジトリ vim/vim における領域外書き込み。(CVE-2022-2288)

- 9.0 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2289)

- 9.0より前の GitHub リポジトリ vim/vim におけるスタックベースのバッファオーバーフロー。(CVE-2022-2304)

- 9.0.0044 より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-2343)

- 9.0.0045 より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-2344)

- 9.0.0046 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2345)

- 9.0.0212 より前の GitHub リポジトリ vim/vim における領域外読み取り。(CVE-2022-2816)

- 9.0.0213 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2817)

- 9.0.0211 より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-2819)

- 9.0.0218 より前の GitHub リポジトリ vim/vim におけるバッファオーバーリード。(CVE-2022-2845)

- 9.0.0220 より前の GitHub リポジトリ vim/vim におけるヒープベースのバッファオーバーフロー。(CVE-2022-2849)

- 9.0.0221 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2862)

- 9.0.0225 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2889)

- 9.0.0240 より前の GitHub リポジトリ vim/vim の NULL ポインターデリファレンス。(CVE-2022-2923)

- 9.0.0246 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2946)

- 9.0.0259 より前の GitHub リポジトリ vim/vim の NULL ポインターデリファレンス。(CVE-2022-2980)

- 9.0.0260 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-2982)

- 9.0.0286 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-3016)

- 9.0.0322 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-3037)

- 9.0.0360 より前の GitHub リポジトリ vim/vim でのメモリ解放後使用 (Use-After-Free)。(CVE-2022-3099)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「yum update vim」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2/ALAS-2022-1868.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2257.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2264.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2284.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2285.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2286.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2287.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2288.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2289.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2304.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2343.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2344.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2345.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2816.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2817.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2819.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2845.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2849.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2862.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2889.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2923.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2946.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2980.html

https://alas.aws.amazon.com/cve/html/CVE-2022-2982.html

https://alas.aws.amazon.com/cve/html/CVE-2022-3016.html

https://alas.aws.amazon.com/cve/html/CVE-2022-3037.html

https://alas.aws.amazon.com/cve/html/CVE-2022-3099.html

プラグインの詳細

深刻度: High

ID: 166395

ファイル名: al2_ALAS-2022-1868.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/10/21

更新日: 2022/12/15

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.8

Temporal Score: 5

ベクトル: AV:N/AC:M/Au:N/C:P/I:P/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-2345

CVSS v3

リスクファクター: High

Base Score: 7.8

Temporal Score: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2022-3099

脆弱性情報

CPE: p-cpe:/a:amazon:linux:vim-X11, p-cpe:/a:amazon:linux:vim-common, p-cpe:/a:amazon:linux:vim-data, p-cpe:/a:amazon:linux:vim-debuginfo, p-cpe:/a:amazon:linux:vim-enhanced, p-cpe:/a:amazon:linux:vim-filesystem, p-cpe:/a:amazon:linux:vim-minimal, cpe:/o:amazon:linux:2

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/10/17

脆弱性公開日: 2022/6/30

参照情報

CVE: CVE-2022-2257, CVE-2022-2264, CVE-2022-2284, CVE-2022-2285, CVE-2022-2286, CVE-2022-2287, CVE-2022-2288, CVE-2022-2289, CVE-2022-2304, CVE-2022-2343, CVE-2022-2344, CVE-2022-2345, CVE-2022-2816, CVE-2022-2817, CVE-2022-2819, CVE-2022-2845, CVE-2022-2849, CVE-2022-2862, CVE-2022-2889, CVE-2022-2923, CVE-2022-2946, CVE-2022-2980, CVE-2022-2982, CVE-2022-3016, CVE-2022-3037, CVE-2022-3099

IAVB: 2022-B-0049-S