Amazon Linux 2022 : (ALAS2022-2022-170)

low Nessus プラグイン ID 166992

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-170 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- SELinux 3.2の CIL コンパイラの __cil_verify_classperms にメモリ解放後使用 (Use After Free) があります (
__cil_verify_classpermission および __cil_pre_verify_helper から呼び出されます)。(CVE-2021-36084)

- SELinux 3.2の CIL コンパイラの __cil_verify_classperms にメモリ解放後使用 (Use After Free) があります (
__verify_map_perm_classperms および hashtab_map から呼び出されます)。(CVE-2021-36085)

- SELinux 3.2の CIL コンパイラは、cil_reset_classpermission (cil_reset_classperms_set および cil_reset_classperms_list から呼び出されます) にメモリ解放後使用 (Use After Free) があります。(CVE-2021-36086)

- SELinux 3.2の CIL コンパイラの ebitmap_match_any にヒープベースのバッファオーバーリードがあります (cil_check_neverallow から間接的に呼び出されます)。これは、オプションのブロックで無効なステートメントのチェックがない場合があるために発生します。(CVE-2021-36087)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「dnf update libsepol --releasever=2022.0.20221102」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-170.html

https://alas.aws.amazon.com/cve/html/CVE-2021-36084.html

https://alas.aws.amazon.com/cve/html/CVE-2021-36085.html

https://alas.aws.amazon.com/cve/html/CVE-2021-36086.html

https://alas.aws.amazon.com/cve/html/CVE-2021-36087.html

プラグインの詳細

深刻度: Low

ID: 166992

ファイル名: al2022_ALAS2022-2022-170.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/4

更新日: 2022/11/4

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 2.2

CVSS v2

リスクファクター: Low

Base Score: 2.1

Temporal Score: 1.6

ベクトル: AV:L/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2021-36087

CVSS v3

リスクファクター: Low

Base Score: 3.3

Temporal Score: 2.9

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:libsepol, p-cpe:/a:amazon:linux:libsepol-debuginfo, p-cpe:/a:amazon:linux:libsepol-debugsource, p-cpe:/a:amazon:linux:libsepol-devel, p-cpe:/a:amazon:linux:libsepol-static, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/1

脆弱性公開日: 2021/7/1

参照情報

CVE: CVE-2021-36084, CVE-2021-36085, CVE-2021-36086, CVE-2021-36087