Amazon Linux 2022 : (ALAS2022-2022-162)

low Nessus プラグイン ID 167006

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-162 のアドバイザリに記載されている脆弱性の影響を受けます。

- zziplib v0.13.69 の無限ループにより、リモートの攻撃者が関数 unzzip_cat_file の戻り値 zzip_file_read を介してサービス拒否を引き起こす可能性があります。(CVE-2020-18442)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「dnf update zziplib --releasever=2022.0.20221102」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-162.html

https://alas.aws.amazon.com/cve/html/CVE-2020-18442.html

プラグインの詳細

深刻度: Low

ID: 167006

ファイル名: al2022_ALAS2022-2022-162.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2022/11/4

更新日: 2022/11/4

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 2.2

CVSS v2

リスクファクター: Low

Base Score: 2.1

Temporal Score: 1.6

ベクトル: AV:L/AC:L/Au:N/C:N/I:N/A:P

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2020-18442

CVSS v3

リスクファクター: Low

Base Score: 3.3

Temporal Score: 2.9

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:N/I:N/A:L

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:zziplib, p-cpe:/a:amazon:linux:zziplib-debuginfo, p-cpe:/a:amazon:linux:zziplib-debugsource, p-cpe:/a:amazon:linux:zziplib-devel, p-cpe:/a:amazon:linux:zziplib-utils, p-cpe:/a:amazon:linux:zziplib-utils-debuginfo, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/1

脆弱性公開日: 2021/6/18

参照情報

CVE: CVE-2020-18442