Amazon Linux 2022 : (ALAS2022-2022-190)

high Nessus プラグイン ID 167014

概要

リモートの Amazon Linux 2022 ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS2022-2022-190 のアドバイザリに記載されている脆弱性の影響を受けます。

- PostgreSQL に欠陥が見つかりました。権限のあるユーザーが別のユーザーのオブジェクトを管理している場合に、安全に操作するための取り組みが不完全であるという問題があります。Autovacuum、REINDEX、CREATE INDEX、REFRESH MATERIALIZED VIEW、CLUSTER、および pg_amcheck コマンドは、関連する保護をアクティブ化するのが遅すぎるか、処理の際にまったく動作しません。この欠陥により、少なくとも 1 つのスキーマで非一時オブジェクトを作成する権限を持つ攻撃者が、スーパーユーザーの ID で任意の SQL 関数を実行する場合があります。(CVE-2022-1552)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存しています。

ソリューション

「dnf update postgresql14 --releasever=2022.0.20221102」を実行してシステムを更新してください。

関連情報

https://alas.aws.amazon.com/AL2022/ALAS-2022-190.html

https://alas.aws.amazon.com/cve/html/CVE-2022-1552.html

プラグインの詳細

深刻度: High

ID: 167014

ファイル名: al2022_ALAS2022-2022-190.nasl

バージョン: 1.4

タイプ: local

エージェント: unix

公開日: 2022/11/5

更新日: 2022/11/28

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Frictionless Assessment AWS, Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 6.7

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-1552

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:postgresql14, p-cpe:/a:amazon:linux:postgresql14-contrib, p-cpe:/a:amazon:linux:postgresql14-contrib-debuginfo, p-cpe:/a:amazon:linux:postgresql14-debuginfo, p-cpe:/a:amazon:linux:postgresql14-debugsource, p-cpe:/a:amazon:linux:postgresql14-docs, p-cpe:/a:amazon:linux:postgresql14-docs-debuginfo, p-cpe:/a:amazon:linux:postgresql14-llvmjit, p-cpe:/a:amazon:linux:postgresql14-llvmjit-debuginfo, p-cpe:/a:amazon:linux:postgresql14-plperl, p-cpe:/a:amazon:linux:postgresql14-plperl-debuginfo, p-cpe:/a:amazon:linux:postgresql14-plpython3, p-cpe:/a:amazon:linux:postgresql14-plpython3-debuginfo, p-cpe:/a:amazon:linux:postgresql14-pltcl, p-cpe:/a:amazon:linux:postgresql14-pltcl-debuginfo, p-cpe:/a:amazon:linux:postgresql14-private-devel, p-cpe:/a:amazon:linux:postgresql14-private-libs, p-cpe:/a:amazon:linux:postgresql14-private-libs-debuginfo, p-cpe:/a:amazon:linux:postgresql14-server, p-cpe:/a:amazon:linux:postgresql14-server-debuginfo, p-cpe:/a:amazon:linux:postgresql14-server-devel, p-cpe:/a:amazon:linux:postgresql14-server-devel-debuginfo, p-cpe:/a:amazon:linux:postgresql14-static, p-cpe:/a:amazon:linux:postgresql14-test, p-cpe:/a:amazon:linux:postgresql14-test-debuginfo, p-cpe:/a:amazon:linux:postgresql14-test-rpm-macros, p-cpe:/a:amazon:linux:postgresql14-upgrade, p-cpe:/a:amazon:linux:postgresql14-upgrade-debuginfo, p-cpe:/a:amazon:linux:postgresql14-upgrade-devel, p-cpe:/a:amazon:linux:postgresql14-upgrade-devel-debuginfo, cpe:/o:amazon:linux:2022

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/1

脆弱性公開日: 2022/5/11

参照情報

CVE: CVE-2022-1552

IAVB: 2022-B-0015-S