FreeBSD: sudo -- 小さなパスワードに対する領域外書き込みの可能性 (3310014a-5ef9-11ed-812b-206a8a720317)

high Nessus プラグイン ID 167057

言語:

概要

リモートの FreeBSD ホストに 1 つ以上のセキュリティ関連の更新プログラムがありません。

説明

リモートホストにインストールされている FreeBSD のバージョンは、テスト済みバージョンより前です。したがって、3310014a-5ef9-11ed-812b-206a8a720317 のアドバイザリに記載されている脆弱性の影響を受けます。

- Sudo 1.8.0 から 1.9.12 の crypt() パスワードバックエンドには plugins/sudoers/auth/passwd.c の array-out-of-bounds エラーがあり、ヒープベースのバッファオーバーリードが発生する可能性があります。これは、Sudo にアクセスできる任意のローカルユーザーが 7 文字以下のパスワードを入力することで引き起こされる可能性があります。システムライブラリ、コンパイラ、プロセッサアーキテクチャによって、影響が異なる可能性があります。(CVE-2022-43995)

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

関連情報

https://cve.mitre.org/cgi-bin/cvename.cgi?name=CVE-2022-43995

http://www.nessus.org/u?580a1d4a

プラグインの詳細

深刻度: High

ID: 167057

ファイル名: freebsd_pkg_3310014a5ef911ed812b206a8a720317.nasl

バージョン: 1.3

タイプ: local

公開日: 2022/11/8

更新日: 2022/11/30

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Medium

Base Score: 6.2

Temporal Score: 4.6

ベクトル: AV:L/AC:L/Au:S/C:C/I:N/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-43995

CVSS v3

リスクファクター: High

Base Score: 7.1

Temporal Score: 6.2

ベクトル: CVSS:3.0/AV:L/AC:L/PR:L/UI:N/S:U/C:H/I:N/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:freebsd:freebsd:sudo, cpe:/o:freebsd:freebsd

必要な KB アイテム: Host/local_checks_enabled, Host/FreeBSD/release, Host/FreeBSD/pkg_info

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/7

脆弱性公開日: 2022/11/2

参照情報

CVE: CVE-2022-43995