Samba < 4.15.12、4.16.x < 4.16.7、および 4.17.x < 4.17.3 32 ビットシステムのバッファオーバーフロー

high Nessus プラグイン ID 168018

概要

リモート Samba サーバーは、バッファオーバーフローの脆弱性の影響を受ける可能性があります。

説明

リモートホストで実行されている Samba のバージョンは、4.15.12 より前、4.16.7 より前の 4.16.x、4.17.3 より前の 4.17.x です。
したがって、バッファに割り当てるバイトの計算ミスにより、バンドルされた Kerberos ライブラリのバッファオーバーフロー状態の影響を受ける可能性があります。認証されたリモートの攻撃者がこれを悪用し、権限属性証明書を含む特別に細工されたチケットを介して、サービス拒否状態を引き起こしたり、メモリの境界を超えて読み取ったりする可能性があります。

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

Samba バージョン 4.15.12、4.16.7、4.17.3 以降にアップグレードしてください。

関連情報

https://www.samba.org/samba/security/CVE-2022-42898.html

プラグインの詳細

深刻度: High

ID: 168018

ファイル名: samba_cve_2022-42898.nasl

バージョン: 1.4

タイプ: remote

ファミリー: Misc.

公開日: 2022/11/21

更新日: 2023/1/6

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 6.7

ベクトル: CVSS2#AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-42898

CVSS v3

リスクファクター: High

Base Score: 8.8

Temporal Score: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:samba:samba:*:*:*:*:*:*:*:*

必要な KB アイテム: SMB/samba, SMB/NativeLanManager

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/15

脆弱性公開日: 2022/11/15

参照情報

CVE: CVE-2022-42898

IAVA: 2022-A-0495-S