RHEL 8: grub2 (RHSA-2022: 8800)

high Nessus プラグイン ID 168416

概要

リモートの Red Hat ホストに 1 つ以上のセキュリティ更新プログラムがありません。

説明

リモート Redhat Enterprise Linux 8 ホストにインストールされているパッケージは、RHSA-2022: 8800 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- grub2: grub_font_construct_glyph() のバッファオーバーフローにより、領域外書き込みおよび安全なブートバイパスが発生する可能性があります (CVE-2022-2601)

- grub2: 特定の unicode シーケンスをレンダリングする際のヒープベースの領域外書き込み (CVE-2022-3775)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

http://www.nessus.org/u?9c5734b1

https://access.redhat.com/security/updates/classification/#moderate

https://access.redhat.com/errata/RHSA-2022:8800

https://bugzilla.redhat.com/show_bug.cgi?id=2112975

https://bugzilla.redhat.com/show_bug.cgi?id=2138880

プラグインの詳細

深刻度: High

ID: 168416

ファイル名: redhat-RHSA-2022-8800.nasl

バージョン: 1.7

タイプ: local

エージェント: unix

公開日: 2022/12/6

更新日: 2024/4/28

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: High

スコア: 7.3

CVSS v2

リスクファクター: High

基本値: 7.2

現状値: 5.6

ベクトル: CVSS2#AV:L/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2022-2601

CVSS v3

リスクファクター: High

基本値: 8.6

現状値: 7.7

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:C/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:redhat:rhel_aus:8.2, cpe:/o:redhat:rhel_e4s:8.2, cpe:/o:redhat:rhel_tus:8.2, p-cpe:/a:redhat:enterprise_linux:grub2, p-cpe:/a:redhat:enterprise_linux:grub2-common, p-cpe:/a:redhat:enterprise_linux:grub2-efi-aa64-modules, p-cpe:/a:redhat:enterprise_linux:grub2-efi-ia32, p-cpe:/a:redhat:enterprise_linux:grub2-efi-ia32-cdboot, p-cpe:/a:redhat:enterprise_linux:grub2-efi-ia32-modules, p-cpe:/a:redhat:enterprise_linux:grub2-efi-x64, p-cpe:/a:redhat:enterprise_linux:grub2-efi-x64-cdboot, p-cpe:/a:redhat:enterprise_linux:grub2-efi-x64-modules, p-cpe:/a:redhat:enterprise_linux:grub2-pc, p-cpe:/a:redhat:enterprise_linux:grub2-pc-modules, p-cpe:/a:redhat:enterprise_linux:grub2-ppc64le, p-cpe:/a:redhat:enterprise_linux:grub2-ppc64le-modules, p-cpe:/a:redhat:enterprise_linux:grub2-tools, p-cpe:/a:redhat:enterprise_linux:grub2-tools-efi, p-cpe:/a:redhat:enterprise_linux:grub2-tools-extra, p-cpe:/a:redhat:enterprise_linux:grub2-tools-minimal

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2022/12/6

脆弱性公開日: 2022/11/15

参照情報

CVE: CVE-2022-2601, CVE-2022-3775

CWE: 787

RHSA: 2022:8800