GitLab < 15.3.5 / 15.4 < 15.4.4 / 15.5< 15.5.2 XSS

medium Nessus プラグイン ID 169427

概要

リモート Web サーバーで実行されているソース管理アプリケーションは、クロスサイトスクリプティングの脆弱性の影響を受けます。

説明

自己報告されたバージョンによると、リモートの Web サーバーで実行されている GitLab のインスタンスは 15.3.5より前、15.4.4 より前の 15.4、15.5.2 より前の 15.5です。したがって、クロスサイトスクリプティングの脆弱性の影響を受け、攻撃者が被害者の代わりに Gitlab で任意の Javascript コードを実行する可能性があります。

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

GitLab バージョン 15.3.5、15.4.4、15.5.2 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?137f15ae

https://nvd.nist.gov/vuln/detail/CVE-2022-3265

プラグインの詳細

深刻度: Medium

ID: 169427

ファイル名: gitlab_cve-2022-3265.nasl

バージョン: 1.1

タイプ: combined

エージェント: unix

ファミリー: CGI abuses

公開日: 2022/12/30

更新日: 2023/1/2

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Low

スコア: 3

CVSS v2

リスクファクター: Medium

Base Score: 5.5

Temporal Score: 4.1

ベクトル: CVSS2#AV:N/AC:L/Au:S/C:P/I:P/A:N

現状ベクトル: CVSS2#E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-3265

CVSS v3

リスクファクター: Medium

Base Score: 5.4

Temporal Score: 4.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:C/C:L/I:L/A:N

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:2.3:a:gitlab:gitlab:*:*:*:*:*:*:*:*

必要な KB アイテム: installed_sw/GitLab

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/11/2

脆弱性公開日: 2022/11/2

参照情報

CVE: CVE-2022-3265

IAVA: 2022-A-0468-S