GitLab 15.6 < 15.6.1 の不適切なサニタイズ

high Nessus プラグイン ID 170066

概要

リモート Web サーバーで実行中のソース制御アプリケーションは、ユーザー指定入力の脆弱性の影響を受けます。

説明

- GitLab CE に問題が発見されました。これは、15.6.1 より前の 15.6 から始まるすべてのバージョンに影響を与えます。ユーザー指定の入力が不適切に中立化されているため、悪意のある README ページが作成される可能性がありました。

Nessus はこの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

GitLab バージョン 15.6.1 以降にアップグレードしてください。

関連情報

http://www.nessus.org/u?ffedd7a6

プラグインの詳細

深刻度: High

ID: 170066

ファイル名: gitlab_CVE-2022-4092.nasl

バージョン: 1.4

タイプ: combined

エージェント: unix

ファミリー: CGI abuses

公開日: 2023/1/16

更新日: 2023/2/2

構成: 徹底的なチェックを有効にする

サポートされているセンサー: Nessus Agent

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 9

Temporal Score: 6.7

ベクトル: AV:N/AC:L/Au:S/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

CVSS スコアのソース: CVE-2022-4092

CVSS v3

リスクファクター: High

Base Score: 8

Temporal Score: 7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:L/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: E:U/RL:O/RC:C

脆弱性情報

CPE: cpe:/a:gitlab:gitlab

必要な KB アイテム: installed_sw/GitLab

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2022/12/12

脆弱性公開日: 2022/12/12

参照情報

CVE: CVE-2022-4092

IAVA: 2022-A-0506-S