Amazon Linux 2: ghostscript (ALAS-2023-2003)

high Nessus プラグイン ID 173240

概要

リモートの Amazon Linux 2 ホストにセキュリティ更新プログラムがありません。

説明

リモートのホストにインストールされているghostscriptのバージョンは、9.25-5より前です。したがって、ALAS2-2023-2003 のアドバイザリに記載されている脆弱性の影響を受けます。

- 9.26までの Artifex Ghostscript が .completefont を不適切に処理します。注意: この問題はCVE-2019-3839の修正が不完全なために存在します。(CVE-2019-25059)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

「yum update ghostscript」を実行してシステムを更新してください。

参考資料

https://alas.aws.amazon.com/AL2/ALAS-2023-2003.html

https://alas.aws.amazon.com/cve/html/CVE-2019-25059.html

https://alas.aws.amazon.com/faqs.html

プラグインの詳細

深刻度: High

ID: 173240

ファイル名: al2_ALAS-2023-2003.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2023/3/22

更新日: 2023/3/22

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

基本値: 6.8

現状値: 5

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2019-25059

CVSS v3

リスクファクター: High

基本値: 7.8

現状値: 6.8

ベクトル: CVSS:3.0/AV:L/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:amazon:linux:ghostscript, p-cpe:/a:amazon:linux:ghostscript-cups, p-cpe:/a:amazon:linux:ghostscript-debuginfo, p-cpe:/a:amazon:linux:ghostscript-doc, p-cpe:/a:amazon:linux:ghostscript-gtk, p-cpe:/a:amazon:linux:libgs, p-cpe:/a:amazon:linux:libgs-devel, cpe:/o:amazon:linux:2

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2023/3/17

脆弱性公開日: 2022/4/25

参照情報

CVE: CVE-2019-25059