Amazon Linux AMI: python-twisted-web (ALAS-2023-1717)

high Nessus プラグイン ID 173953

概要

リモートの Amazon Linux AMI ホストに、セキュリティ更新プログラムがありません。

説明

したがって、ALAS-2023-1717 のアドバイザリに記載されている複数の脆弱性の影響を受けます。

- Twisted は、Python 3.6+ をサポートする、イベントベースのインターネットアプリケーション用フレームワークです。バージョン 22.4.0rc1 より前は、「twisted.web.http」モジュールにある Twisted Web HTTP 1.1サーバーが、RFC 7230 で許可されているよりも緩やかに複数の HTTP リクエストコンストラクトを解析していました。この非準拠解析により、リクエストが複数の HTTP パーサーを通過する場合に非同期が発生し、HTTP リクエストスマグリングが発生する可能性があります。
影響を受ける可能性があるユーザーは、Twisted Web の HTTP 1.1サーバーおよび / またはプロキシを使用し、別の HTTP サーバーおよび / またはプロキシを介してリクエストを渡します。Twisted Web クライアントは影響を受けません。HTTP 2.0サーバーは異なるパーサーを使用するため、影響を受けません。この問題は、Twisted 22.4.0rc1 で対処されています。2 つの回避策が利用可能です: Upstream プロキシの脆弱性がアップグレードなどによって対処されていることを確認します。または、Upstream プロキシの構成など、他の手段で無効な形式のリクエストをフィルタリングします。
(CVE-2022-24801)

- Twisted は、イベントベースのインターネットアプリケーション用フレームワークです。バージョン 0.9.4で開始し、ホストヘッダーが構成済みのホスト「twisted.web.vhost.NameVirtualHost」と一致しない場合、「NoResource」リソースを返すため、ホストヘッダーが 404 応答にエスケープされず、HTML とスクリプトのインジェクションが可能になります。
実際には、これを悪用することは非常に困難です。通常の HTTP リクエストのホストヘッダーを変更できるということは、すでに権限のある立場にいることを意味しているからです。この問題は、バージョン 22.10.0rc1 で修正されました。既知の回避策はありません。(CVE-2022-39348)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

「yum update python-twisted-web」を実行してシステムを更新してください。

参考資料

https://alas.aws.amazon.com/ALAS-2023-1717.html

https://alas.aws.amazon.com/cve/html/CVE-2022-24801.html

https://alas.aws.amazon.com/cve/html/CVE-2022-39348.html

https://alas.aws.amazon.com/faqs.html

プラグインの詳細

深刻度: High

ID: 173953

ファイル名: ala_ALAS-2023-1717.nasl

バージョン: 1.1

タイプ: local

エージェント: unix

公開日: 2023/4/6

更新日: 2023/4/19

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: Medium

基本値: 6.8

現状値: 5.3

ベクトル: CVSS2#AV:N/AC:M/Au:N/C:P/I:P/A:P

CVSS スコアのソース: CVE-2022-24801

CVSS v3

リスクファクター: High

基本値: 8.1

現状値: 7.3

ベクトル: CVSS:3.0/AV:N/AC:H/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:P/RL:O/RC:C

脆弱性情報

CPE: cpe:/o:amazon:linux, p-cpe:/a:amazon:linux:python26-twisted-web, p-cpe:/a:amazon:linux:python27-twisted-web

必要な KB アイテム: Host/local_checks_enabled, Host/AmazonLinux/release, Host/AmazonLinux/rpm-list

エクスプロイトが利用可能: true

エクスプロイトの容易さ: Exploits are available

パッチ公開日: 2023/3/30

脆弱性公開日: 2022/4/4

参照情報

CVE: CVE-2022-24801, CVE-2022-39348