OpenSSL < 0.9.8p/1.0.0bのバッファオーバーフロー

high Nessus プラグイン ID 17766
New! プラグインの深刻度には CVSS v3 が適用されるようになりました。

プラグインの深刻度は、デフォルトで CVSS v3 を使って計算されるように更新されました。プラグインに CVSS v3 スコアがない場合には、CVSS v2 を使って深刻度が計算されます。深刻度の表示設定は、[設定]のドロップダウンで切り替えができます。

概要

リモートサーバーは、バッファオーバーフロー脆弱性の影響を受けます。

説明

バナーによると、リモートサーバーで 0.9.8p / 1.0.0b より前のバージョンの OpenSSL が実行されています。

TLS サーバーがマルチスレッド化されていて、SSL キャッシュを使用する場合、リモートの攻撃者はバッファオーバーフローをトリガし、サーバーをクラッシュするか任意のコードを実行することがあります。

ソリューション

OpenSSL 0.9.8p/1.0.0b以降にアップグレードしてください。

関連情報

https://www.openssl.org/news/secadv/20101116.txt

プラグインの詳細

深刻度: High

ID: 17766

ファイル名: openssl_0_9_8p_1_0_0b.nasl

バージョン: 1.10

タイプ: remote

ファミリー: Web Servers

公開日: 2012/1/4

更新日: 2018/7/16

依存関係: openssl_version.nasl

リスク情報

VPR

リスクファクター: Medium

スコア: 5.9

CVSS v2

リスクファクター: High

Base Score: 7.6

Temporal Score: 5.6

ベクトル: AV:N/AC:H/Au:N/C:C/I:C/A:C

現状ベクトル: E:U/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:openssl:openssl

必要な KB アイテム: openssl/port

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2010/11/16

脆弱性公開日: 2010/11/16

参照情報

CVE: CVE-2010-3864

BID: 44884