PHP 4.x < 4.3.0 の ZendEngine の整数オーバーフロー

high Nessus プラグイン ID 17796

概要

任意のコードがリモートサーバーで実行されることがあります。

説明

リモートホストで 4.3.0 より前のバージョンの PHP 4.x が実行されています。それ自体、報告されているところによれば、配列作成に整数オーバーフローがあり、これは「unserialize()」関数に渡されるユーザー入力によってトリガされることがあります。

この脆弱性の悪用に成功すると、攻撃者がこのホストで任意のコードを実行できることがあります。

ソリューション

PHP 4.3.0 または以降にアップグレードしてください。

関連情報

http://www.hardened-php.net/advisory_092006.133.html

プラグインの詳細

深刻度: High

ID: 17796

ファイル名: php_4_3_0_zendengine.nasl

バージョン: 1.7

タイプ: remote

ファミリー: CGI abuses

公開日: 2012/1/11

更新日: 2022/4/11

構成: 徹底的なチェックを有効にする

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: High

Base Score: 7.5

Temporal Score: 5.9

ベクトル: AV:N/AC:L/Au:N/C:P/I:P/A:P

現状ベクトル: E:POC/RL:OF/RC:C

脆弱性情報

CPE: cpe:/a:php:php

必要な KB アイテム: www/PHP

エクスプロイトの容易さ: No exploit is required

脆弱性公開日: 2006/10/5

参照情報

CVE: CVE-2006-4812

BID: 20349

CWE: 94