Fedora 37: community-mysql (2023-a9283d639f)

medium Nessus プラグイン ID 181491

Language:

概要

リモートの Fedora ホストに 1 つ以上のセキュリティ更新プログラムがありません。

説明

リモートの Fedora 37 ホストには、FEDORA-2023-a9283d639f のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: InnoDB)。影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21911)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: DDL) 影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21919、CVE-2023-21933)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Optimizer)。影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21920、CVE-2023-21935、CVE-2023-21945)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: DDL) 影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性による攻撃が成功すると、権限なしで MySQL Server がアクセスできるデータの一部にアクセスして、更新、挿入、削除したり、さらに MySQL Server でハングを引き起こしたり、頻繁にクラッシュを繰り返させたりする (完全な DOS) 可能性があります。(CVE-2023-21929)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: コンポーネントサービス)。
影響を受けるサポート対象のバージョンは 8.0.32以前です。悪用が難しい脆弱性ですが、権限が高い攻撃者が複数のプロトコルを使用してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21940、CVE-2023-21947)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Optimizer)。影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、権限が低い攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21946)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: パーティション) 影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21953、CVE-2023-21955)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: コンポーネントサービス)。
影響を受けるサポート対象のバージョンは 8.0.32以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-21962)

-zstd v1.4.10 に脆弱性が見つかりました。攻撃者がコマンドラインツールに引数として空の文字列を指定し、バッファオーバーランを引き起こす可能性があります。(CVE-2022-4899)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Replication)。影響を受けるサポート対象のバージョンは8.0.33以前です。悪用が難しい脆弱性ですが、権限が高い攻撃者が複数のプロトコルを使用してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-22005)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: InnoDB)。影響を受けるサポート対象のバージョンは 8.0.33以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-22008)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: InnoDB)。影響を受けるサポート対象のバージョンは8.0.33以前です。悪用が難しい脆弱性ですが、権限が高い攻撃者が複数のプロトコルを使用してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-22033)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Security: 特権)。
影響を受けるサポート対象のバージョンは8.0.33以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、MySQL Server がアクセスできるいくつかのデータが、権限なしで更新、挿入または削除される可能性があります。(CVE-2023-22038)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Optimizer)。影響を受けるサポート対象のバージョンは 8.0.33以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-22046、CVE-2023-22054、CVE-2023-22056)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Pluggable Auth)。影響を受けるサポート対象のバージョンは8.0.33以前です。悪用が難しい脆弱性ですが、権限が低い攻撃者が複数のプロトコルを使用してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、MySQL Server がアクセスできるサブセットのデータが、権限なく読み取りアクセスされる可能性があります。
(CVE-2023-22048)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: Client programs)。影響を受けるサポート対象のバージョンは 5.7.42以前および 8.0.33以前です。悪用が難しい脆弱性ですが、権限が低い攻撃者が複数のプロトコルを使用してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性による攻撃が成功すると、MySQL サーバーが不正にハングアップしたり、頻繁にクラッシュ (完全な DOS) を繰り返したり、MySQL サーバーのアクセス可能なデータのサブセットへの不正な読み取りアクセスが発生する可能性があります。(CVE-2023-22053)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: Replication)。影響を受けるサポート対象のバージョンは8.0.33以前です。容易に悪用可能な脆弱性により、高い権限を持つ攻撃者が複数のプロトコルを介してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-22057)

- Oracle MySQL の MySQL Server 製品における脆弱性 (コンポーネント: サーバー: DDL) 影響を受けるサポート対象のバージョンは8.0.33以前です。悪用が難しい脆弱性ですが、権限が高い攻撃者が複数のプロトコルを使用してネットワークにアクセスし、MySQL Server を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、権限なく MySQL Server をハングさせたり、頻繁にクラッシュを繰り返させたりする可能性 (完全な DOS) があります。(CVE-2023-22058)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションの自己報告されたバージョン番号にのみ依存しています。

ソリューション

影響を受ける community-mysql パッケージを更新してください。

参考資料

https://bodhi.fedoraproject.org/updates/FEDORA-2023-a9283d639f

プラグインの詳細

深刻度: Medium

ID: 181491

ファイル名: fedora_2023-a9283d639f.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2023/9/16

更新日: 2023/9/21

サポートされているセンサー: Agentless Assessment, Frictionless Assessment Agent, Nessus Agent, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 5.0

CVSS v2

リスクファクター: Medium

基本値: 6.8

現状値: 5

ベクトル: CVSS2#AV:N/AC:L/Au:M/C:N/I:P/A:C

CVSS スコアのソース: CVE-2023-21929

CVSS v3

リスクファクター: Medium

基本値: 5.9

現状値: 5.2

ベクトル: CVSS:3.0/AV:N/AC:H/PR:L/UI:N/S:U/C:L/I:N/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

CVSS スコアのソース: CVE-2023-22053

脆弱性情報

CPE: cpe:/o:fedoraproject:fedora:37, p-cpe:/a:fedoraproject:fedora:community-mysql

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2023/9/7

脆弱性公開日: 2023/3/31

参照情報

CVE: CVE-2022-4899, CVE-2023-21911, CVE-2023-21919, CVE-2023-21920, CVE-2023-21929, CVE-2023-21933, CVE-2023-21935, CVE-2023-21940, CVE-2023-21945, CVE-2023-21946, CVE-2023-21947, CVE-2023-21953, CVE-2023-21955, CVE-2023-21962, CVE-2023-22005, CVE-2023-22008, CVE-2023-22033, CVE-2023-22038, CVE-2023-22046, CVE-2023-22048, CVE-2023-22053, CVE-2023-22054, CVE-2023-22056, CVE-2023-22057, CVE-2023-22058