SUSE SLED15 / SLES15 / openSUSE 15 セキュリティ更新: MozillaThunderbird (SUSE-SU-2024:0044-1)

high Nessus プラグイン ID 187723

Language:

概要

リモートの SUSE ホストに 1 つ以上のセキュリティ更新がありません。

説明

リモートの SUSE Linux SLED15 / SLED_SAP15 / SLES15 / SLES_SAP15 / openSUSE 15 ホストには、SUSE-SU-2024:0044-1 のアドバイザリに記載された複数の脆弱性の影響を受けるパッケージがインストールされています。

- デジタル署名された S/MIME メールメッセージの署名では、オプションで署名作成日時を指定できます。存在する場合、Thunderbird は署名作成日とメッセージの日時を比較せず、日付または時刻の不一致があっても有効な署名を表示していました。これにより、受信者に対してメッセージが異なる日付や時間に送信されたかのような印象を与えることができました。この脆弱性の影響を受けるのは、Thunderbird < 115.6です。(CVE-2023-50761)

- デジタル署名されたテキストを含む PGP/MIME ペイロードを処理する際、テキストの最初の段落がユーザーに表示されていませんでした。これは、テキストが MIME メッセージとして解釈され、最初の段落が常にメールヘッダーセクションとして扱われるためです。署名された GIT コミットなど、異なるコンテキストからのデジタル署名されたテキストが、メールメッセージのなりすましに使用される可能性があります。この脆弱性の影響を受けるのは、Thunderbird < 115.6です。(CVE-2023-50762)

- WebGL `DrawElementsInstanced` メソッドは、Mesa VM ドライバーを搭載したシステムで使用されると、ヒープバッファオーバーフローの影響を受けやすい状態でした。この問題により、攻撃者がリモートでコードを実行したり、サンドボックスを回避したりする可能性があります。この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。
(CVE-2023-6856)

- シンボリックリンクを解決する際に、競合が発生し、`readlink` に渡されるバッファが実際には必要より小さい場合があります。*このバグは、Unix ベースのオペレーティングシステム (Android、Linux、MacOS) の Firefox にのみ影響します。
Windows は影響を受けません。* この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。(CVE-2023-6857)

- Firefox は、OOM 処理が不十分なため `nsTextFragment` のヒープバッファオーバーフローの影響を受けます。
この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。(CVE-2023-6858)

- メモリが圧迫されているとき、メモリ解放後使用 (Use After Free) 状態が TLS ソケットの作成に影響を与えます。この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。(CVE-2023-6859)

- `VideoBridge` により、コンテンツプロセスが、リモートデコーダーによって生成されたテクスチャを使用する可能性があります。これは、サンドボックスをエスケープするために悪用される可能性があります。この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。(CVE-2023-6860)

- `nsWindow: : PickerOpen(void)` メソッドは、ヘッドレスモードで実行する際に、ヒープバッファオーバーフローの影響を受けやすくなっていました。この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。
(CVE-2023-6861)

- メモリ解放後使用 (Use After Free) が `nsDNSService: : Init` で特定されました。この問題は起動中にまれに発生します。この脆弱性の影響を受けるのは、Firefox ESR < 115.6 と Thunderbird < 115.6 です。(CVE-2023-6862)

- `ShutdownObserver()` は、仮想デストラクターを持たない動的な型に依存しているため、未定義の動作を引き起こす可能性がありました。この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。(CVE-2023-6863)

- Firefox 120、Firefox ESR 115.5、および Thunderbird 115.5 に存在するメモリの安全性のバグ。これらのバグの一部にはメモリ破損の証拠が示されており、当社では、手間をかけることにより、これらの一部が悪用され、任意のコードが実行される可能性があると推測しています。この脆弱性の影響を受けるのは、Firefox ESR < 115.6、Thunderbird < 115.6、Firefox < 121 です。(CVE-2023-6864)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

影響を受ける MozillaThunderbird、MozillaThunderbird-translations-common や MozillaThunderbird-translations- その他のパッケージを更新してください。

参考資料

https://bugzilla.suse.com/1217974

http://www.nessus.org/u?ed6873c2

https://www.suse.com/security/cve/CVE-2023-50761

https://www.suse.com/security/cve/CVE-2023-50762

https://www.suse.com/security/cve/CVE-2023-6856

https://www.suse.com/security/cve/CVE-2023-6857

https://www.suse.com/security/cve/CVE-2023-6858

https://www.suse.com/security/cve/CVE-2023-6859

https://www.suse.com/security/cve/CVE-2023-6860

https://www.suse.com/security/cve/CVE-2023-6861

https://www.suse.com/security/cve/CVE-2023-6862

https://www.suse.com/security/cve/CVE-2023-6863

https://www.suse.com/security/cve/CVE-2023-6864

プラグインの詳細

深刻度: High

ID: 187723

ファイル名: suse_SU-2024-0044-1.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2024/1/9

更新日: 2024/1/9

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Critical

基本値: 10

現状値: 7.4

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2023-6864

CVSS v3

リスクファクター: High

基本値: 8.8

現状値: 7.7

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:R/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:mozillathunderbird, p-cpe:/a:novell:suse_linux:mozillathunderbird-translations-common, p-cpe:/a:novell:suse_linux:mozillathunderbird-translations-other, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/1/7

脆弱性公開日: 2023/12/19

参照情報

CVE: CVE-2023-50761, CVE-2023-50762, CVE-2023-6856, CVE-2023-6857, CVE-2023-6858, CVE-2023-6859, CVE-2023-6860, CVE-2023-6861, CVE-2023-6862, CVE-2023-6863, CVE-2023-6864

SuSE: SUSE-SU-2024:0044-1