RHEL 9 : java-17-openjdk (RHSA-2024: 0244)

high Nessus プラグイン ID 189137

概要

リモートの Red Hat ホストに 1 つ以上のセキュリティ更新プログラムがありません。

説明

リモートの Redhat Enterprise Linux 9 ホストにインストールされているパッケージは、RHSA-2024: 0244 アドバイザリに記載されている複数の脆弱性の影響を受けます。

- Oracle Java SE の Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: ホットスポット)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 8u391、8u391-perf、11.0.21、17.0.9、21.0.1、Oracle GraalVM for JDK:17.0.9, 21.0.1; Oracle GraalVM Enterprise Edition:20.3.12、21.3.8、および 22.3.4です。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータや Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition がアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があるとともに、権限なしで重要なデータにアクセスできるようになったり、Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition がアクセスできるすべてのデータに完全にアクセスできるようになったりする可能性があります。
注意: この脆弱性は、指定されたコンポーネントで API を使用することによって (例えば API にデータを提供する Web サービスを通して) 悪用される可能性があります。この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントも対象です。
(CVE-2024-20918)

- hotspot/runtime (CVE-2024-20919)

- hotspot/compiler (CVE-2024-20921)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: セキュリティ)。サポートされているバージョンで影響を受けるのは、Oracle Java SE:17.0.9;
Oracle GraalVM for JDK:17.0.9 と Oracle GraalVM Enterprise Edition:21.3.8および22.3.4です。容易に悪用できる脆弱性により、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータや Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition がアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があります。注意: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、通常サーバーで信頼できるコード (管理者がインストールしたコードなど) のみを読み込んで実行する Java デプロイメントを対象としていません。(CVE-2024-20932)

- security-libs/javax.xml.crypto (CVE-2024-20945)

- Oracle Java SE の Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition 製品の脆弱性 (コンポーネント: セキュリティ)。サポートされているバージョンで影響を受けるのは、Oracle Java SE: 8u391、8u391-perf、11.0.21、17.0.9、21.0.1、Oracle GraalVM for JDK:17.0.9, 21.0.1; Oracle GraalVM Enterprise Edition:20.3.12、21.3.8、および 22.3.4です。悪用が難しい脆弱性ですが、認証されていない攻撃者が複数のプロトコルを使用してネットワークにアクセスし、Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition を侵害する可能性があります。この脆弱性に対する攻撃が成功すると、重要なデータや Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition がアクセスできるすべてのデータが権限なしで作成、削除、変更される可能性があるとともに、権限なしで重要なデータにアクセスできるようになったり、Oracle Java SE、Oracle GraalVM for JDK、Oracle GraalVM Enterprise Edition がアクセスできるすべてのデータに完全にアクセスできるようになったりする可能性があります。
注意: この脆弱性は、通常、サンドボックス化された Java Web Start アプリケーションまたはサンドボックス化された Java アプレットを実行しているクライアントで信頼できないコード (インターネットからのコードなど) を読み込んで実行し、セキュリティを Java サンドボックスに依存する Java デプロイメントが対象です。この脆弱性は、通常サーバーで信頼できるコード (管理者がインストールしたコードなど) のみを読み込んで実行する Java デプロイメントを対象としていません。(CVE-2024-20952)

Nessus はこれらの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

http://www.nessus.org/u?2e047530

https://access.redhat.com/security/updates/classification/#important

https://bugzilla.redhat.com/show_bug.cgi?id=2257720

https://bugzilla.redhat.com/show_bug.cgi?id=2257728

https://bugzilla.redhat.com/show_bug.cgi?id=2257837

https://bugzilla.redhat.com/show_bug.cgi?id=2257853

https://bugzilla.redhat.com/show_bug.cgi?id=2257859

https://bugzilla.redhat.com/show_bug.cgi?id=2257874

https://access.redhat.com/errata/RHSA-2024:0244

プラグインの詳細

深刻度: High

ID: 189137

ファイル名: redhat-RHSA-2024-0244.nasl

バージョン: 1.2

タイプ: local

エージェント: unix

公開日: 2024/1/17

更新日: 2024/6/3

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.0

CVSS v2

リスクファクター: High

基本値: 7.8

現状値: 5.8

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:N/I:C/A:N

CVSS スコアのソース: CVE-2024-20932

CVSS v3

リスクファクター: High

基本値: 7.5

現状値: 6.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:N/I:H/A:N

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-devel-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-static-libs, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-javadoc-zip, cpe:/o:redhat:rhel_eus:9.0, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-demo-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-static-libs-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-src, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-src-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-demo-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-javadoc, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-headless, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-headless-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-devel, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-headless-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-src-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-jmods-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-devel-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-jmods-slowdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-static-libs-fastdebug, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-demo, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk, p-cpe:/a:redhat:enterprise_linux:java-17-openjdk-jmods

必要な KB アイテム: Host/local_checks_enabled, Host/RedHat/release, Host/RedHat/rpm-list, Host/cpu

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/1/17

脆弱性公開日: 2024/1/16

参照情報

CVE: CVE-2024-20918, CVE-2024-20919, CVE-2024-20921, CVE-2024-20932, CVE-2024-20945, CVE-2024-20952

CWE: 20, 385, 532, 787

RHSA: 2024:0244