SUSE SLED15/ SLES15/ openSUSE 15 セキュリティ更新: libqt5-qtbase (SUSE-SU-2024:0138-1)

critical Nessus プラグイン ID 189210

Language:

概要

リモートの SUSE ホストにセキュリティ更新がありません。

説明

リモートの SUSE Linux SLED15/ SLED_SAP15 / SLES15/ SLES_SAP15 / openSUSE 15 ホストには、SUSE-SU-2024:0138-1 のアドバイザリに記載されている脆弱性の影響を受けるパッケージがインストールされています。

5.15.17 より前、6.2.11 より前の 6.x、6.5.4 より前の 6.3.x から 6.5.x、6.6.2 より前の 6.6.x の Qt の HTTP2 実装で問題が発見されました。network/access/http2/hpacktable.cpp には、間違った HPack 整数オーバーフローチェックがあります。(CVE-2023-51714)

Nessus はこの問題をテストしておらず、代わりにアプリケーションが自己報告するバージョン番号にのみ依存していることに注意してください。

ソリューション

影響を受けるパッケージを更新してください。

参考資料

https://bugzilla.suse.com/1218413

http://www.nessus.org/u?8a0b3222

https://www.suse.com/security/cve/CVE-2023-51714

プラグインの詳細

深刻度: Critical

ID: 189210

ファイル名: suse_SU-2024-0138-1.nasl

バージョン: 1.0

タイプ: local

エージェント: unix

公開日: 2024/1/19

更新日: 2024/1/19

サポートされているセンサー: Frictionless Assessment AWS, Frictionless Assessment Azure, Frictionless Assessment Agent, Nessus Agent, Agentless Assessment, Nessus

リスク情報

VPR

リスクファクター: Medium

スコア: 6.7

CVSS v2

リスクファクター: Critical

基本値: 10

現状値: 7.4

ベクトル: CVSS2#AV:N/AC:L/Au:N/C:C/I:C/A:C

CVSS スコアのソース: CVE-2023-51714

CVSS v3

リスクファクター: Critical

基本値: 9.8

現状値: 8.5

ベクトル: CVSS:3.0/AV:N/AC:L/PR:N/UI:N/S:U/C:H/I:H/A:H

現状ベクトル: CVSS:3.0/E:U/RL:O/RC:C

脆弱性情報

CPE: p-cpe:/a:novell:suse_linux:libqt5concurrent-devel, p-cpe:/a:novell:suse_linux:libqt5concurrent5, p-cpe:/a:novell:suse_linux:libqt5core-devel, p-cpe:/a:novell:suse_linux:libqt5core-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5core5, p-cpe:/a:novell:suse_linux:libqt5dbus-devel, p-cpe:/a:novell:suse_linux:libqt5dbus-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5dbus5, p-cpe:/a:novell:suse_linux:libqt5gui-devel, p-cpe:/a:novell:suse_linux:libqt5gui-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5gui5, p-cpe:/a:novell:suse_linux:libqt5kmssupport-devel-static, p-cpe:/a:novell:suse_linux:libqt5kmssupport-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5network-devel, p-cpe:/a:novell:suse_linux:libqt5network-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5network5, p-cpe:/a:novell:suse_linux:libqt5opengl-devel, p-cpe:/a:novell:suse_linux:libqt5opengl-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5opengl5, p-cpe:/a:novell:suse_linux:libqt5openglextensions-devel-static, p-cpe:/a:novell:suse_linux:libqt5platformheaders-devel, p-cpe:/a:novell:suse_linux:libqt5platformsupport-devel-static, p-cpe:/a:novell:suse_linux:libqt5platformsupport-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5printsupport-devel, p-cpe:/a:novell:suse_linux:libqt5printsupport-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5printsupport5, p-cpe:/a:novell:suse_linux:libqt5sql-devel, p-cpe:/a:novell:suse_linux:libqt5sql-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5sql5, p-cpe:/a:novell:suse_linux:libqt5sql5-mysql, p-cpe:/a:novell:suse_linux:libqt5sql5-postgresql, p-cpe:/a:novell:suse_linux:libqt5sql5-sqlite, p-cpe:/a:novell:suse_linux:libqt5sql5-unixodbc, p-cpe:/a:novell:suse_linux:libqt5test-devel, p-cpe:/a:novell:suse_linux:libqt5test-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5test5, p-cpe:/a:novell:suse_linux:libqt5widgets-devel, p-cpe:/a:novell:suse_linux:libqt5widgets-private-headers-devel, p-cpe:/a:novell:suse_linux:libqt5widgets5, p-cpe:/a:novell:suse_linux:libqt5xml-devel, p-cpe:/a:novell:suse_linux:libqt5xml5, p-cpe:/a:novell:suse_linux:libqt5-qtbase-common-devel, p-cpe:/a:novell:suse_linux:libqt5-qtbase-devel, p-cpe:/a:novell:suse_linux:libqt5-qtbase-platformtheme-gtk3, p-cpe:/a:novell:suse_linux:libqt5-qtbase-private-headers-devel, cpe:/o:novell:suse_linux:15

必要な KB アイテム: Host/local_checks_enabled, Host/cpu, Host/SuSE/release, Host/SuSE/rpm-list

エクスプロイトの容易さ: No known exploits are available

パッチ公開日: 2024/1/18

脆弱性公開日: 2023/12/24

参照情報

CVE: CVE-2023-51714

SuSE: SUSE-SU-2024:0138-1